Content Delivery Network cannot be enabled

hi team,

Hope this message will find you well.
I have tried enabling Hummingbird CDN and saving the updated settings but the toggle keeps jumping back to disabled.

Is the CDN only work if you have connected Cloudflare?

Please advise.
Access will be enabled.

thanks

Ben

  • Oguz

    Hey Nicholas Stehle ,

    Hope you're well today.

    You don't need to use Cloudflare for use of Hummingbird CDN feature. But when I try to go Hummingbird settings page I am getting HTTP 500 error.

    First, can you make plugin conflict test? You can learn how to do that from this page. You just need to deactivate all the plugins and activate them one by one. So you can understand is any plugin cause this error. Be sure you have a backup before any testing.

    Second, try adding following line to the "wp-config.php" file of your site:

    define('WP_MEMORY_LIMIT','256M');

    This should be put above the "/* That's all, stop editing! */" line.

    Third, you can put these to your "wp-config.php" file of your site:

    /* Debug Settings */
    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );
    /* End of Debug Settings */

    This way all errors will be saved in the debug.log file inside the /wp-content/ directory. Rename the debug.log to debug.txt and attach it in this thread so we could have a look at it.

    If you are still having troubles with this you can send us your details through our contact form, please DO NOT post the credential in this thread as support forum is public and this info can be viewed by anyone, you can send us your details here https://premium.wpmudev.org/contact/#i-have-a-different-question using this template:

    Subject: "Attn: Oguz"
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Please use this subject line to ensure that it gets assigned to me :slight_smile:

    Cheers!
    Oguz

  • Jamie

    Hi,

    I've just experienced the same problem with one of my websites. I didn't have Minification enabled at the time, so I clicked to activate it, it would do its checks, then ask if I wanted to enabled the CDN. After pressing submit, it would go back to the Minification screen asking to activate. This was happening all the time, even after reinstalling the plugin.

    I got around it by turning off caching (I'm using WP-Super-Cache) and deleting any existing cache. This solved it (possibly after doing a hard reload of the Hummingbird dashboard page too) and then I was able to turn the caching back on.

    Hopefully this will solve your issue too Ben.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.