Content Monitor Won't Activate

I can install Content Monitor just fine. But when I hit Activate, I get this message:

Sorry, This Plugin requires PHP 5.0 or higher.

I am running PHP 5.2, according to Go Daddy. What's up?