Continually Having to Reset Capabilties

First off, HATE the new design here. The use of the Admin bar is great, but everything else is totally not user friendly. I can't even located the posts that I've made in the past so I can add onto them instead of creating a new one (this being case in point).

Anyway, if someone manages to find my previous post on this plugin, I've come up with a new problem...

I don't know how best to describe this, but ever since this plugin was installed, when an existing user goes to login to the website I have to manually go in and re-save the settings for a role despite having already set them up. If a user tries to login, they get a "You do not have sufficient permission to access this." instead of the dashboard despite the role being set to have access.

This is quite an annoyance as every day I have dozens of users emailing me aggravated that they can not login and I spend an unnecessary amount of time going through and re-saving each website's role settings.

I did post this on the plugin's support forum, but I don't expect much response from the developer as with the previous (still unresolved) problem he was indifferent.

  • aecnu

    Greetings mmedia,

    First off, HATE the new design here. The use of the Admin bar is great, but everything else is totally not user friendly. I can't even located the posts that I've made in the past so I can add onto them instead of creating a new one (this being case in point).

    Sorry that you do not like the new layout, it does take a little getting used to. Also it is obvious then that you are not subscribing to your own tickets via email Be notified of follow-up posts via email

    Also it is easy enough to find posts searching with Google on WPMU Dev by using simple criteria site:wpmudev.org what you are searching for actually works for searching any individual domain that has been spidered by Google :slight_smile:

    Anyway, if someone manages to find my previous post on this plugin, I've come up with a new problem...

    I have no idea what plugin you are referring to. If I knew then I could find your previous post in a heartbeat.

    This is quite an annoyance as every day I have dozens of users emailing me aggravated that they can not login and I spend an unnecessary amount of time going through and re-saving each website's role settings.

    Agreed that this would be annoying and wasted time having to do this no matter what the plugin is that you are using.

    Please advise to what plugin you are referring to and lets see what we can do to stop this annoying anomaly.

    Cheers, Joe

  • mmedia

    Staff here recommended Advanced Access Manager to me for user access control.

    Also it is easy enough to find posts searching with Google on WPMU Dev by using simple criteria site:wpmudev.org what you are searching for actually works for searching any individual domain that has been spidered by Google :slight_smile:

    FYI, this is not user friendly. Having to go to Google to run a special search, hoping I remember the exact title for what I'm looking for.

  • aecnu

    Greetings mmedia,

    The suggestion about searching with Google was not meant to be a permanent solution, it was suggested while we continue tweaking our new site and working out the 50+ different reported anomalies.

    However, I did do a Google search --> site:wpmudev.org mmedia --> and it quickly came up with every ticket you have ever submitted and more concerning your account.

    Which version of Advanced Access Manager are you using? In the last version the change log mentions that this bug was fixed?

    1.6.5.2

    Updated jQuery UI lib to 1.8.20
    Minimized JavaScript
    Implemented Web Service for AWM Group page
    Implemented Web Service for Premium Version
    Fixed bug with User Restrictions
    Fixed bug with Edit Permalink
    Fixed bug with Upgrade Hook
    Reorganized Label Module (Preparing for Russian and Polish transactions)

    And if you continue to have problems with Advanced Access Manager and/or it does not meet your needs due to anomalies or whatever, you may want to try out and use User Role Editor plugin instead.

    Please advise on the version or if indeed you chose to switch.

    Cheers, Joe

  • aecnu

    Greetings mmedia,

    I have no idea what to advise you since we are not the creator of Advanced Access Manager plugin with the exception of doing a full plugin/theme troubleshooting session since not a single other user of this plugin is reporting any problems this clearly gives the impression there is a conflict.

    Now it is time to go into full blown trouble shooting mode because it appears there may be some conflict here and one way to find out conclusively.

    Standard plugin trouble shooting protocol - first to switch to the Twenty Eleven theme just long enough to check for the problem - if the problem still exists next involves deactivating all plugins except the plugin in question and then see if the issue still exists.

    If it does not, then you want to activate plugins one at a time testing in between to see if the issue returns. Even when you find one plugin, it may be in your interest to deactivate the problem plugin and continue testing the rest of the plugins to insure no others are also conflicting. You will know the conflict when the issue returns and which plugin(s) you activated that cause the issue.

    Please advise if there are any plugin conflicts and if so what the plugins are that are conflicting.

    Cheers, Joe

  • mmedia

    Unfortunately we can not switch to twenty-eleven or disable plugins as these are all live websites. I can however provide a list of plugins we're using.

    - Advanced Access Manager
    - AVH First Defense Against Spam
    - Backup Buddy
    - Contact Form 7
    - Enable Multi-Site (I'm not even sure if this is one we need any longer)
    - Expire User Passwords
    - Google Analytics
    - Infinite SEO
    - Multisite User Management
    - MU Support System
    - Network Blog Manager
    - NextGEN Gallery
    - ReCAPTCHA
    - Recent Posts with Excerpts
    - Simple Login Log
    - Social
    - WPMU Dev Dashboard
    - WP Smush.It

  • Mason

    Hiya mmedia,

    First off, you should be able to find all your recent posts directly from your profile page. And a full listing of your threads by clicking the "Show just my forum activity" link:
    https://premium.wpmudev.org/profile/private/

    You can also always view the entire history of your posting here:
    https://premium.wpmudev.org/forums/profile/mmedia

    Hope that helps keep track :slight_smile:

    I've never used Advanced Access Manager, but I'd recommend updating as Joe mentioned. If that doesn't work, you may want to explore the wp_options table for the site where this is activated. Check for any values that begin with "_transient".

    Sometimes these values get stuck and must be manually removed for the update to save correctly. Caching could also play a role in the problem though I don't see any caching plugins installed in your list above.

    Other than that, there isn't much we can do to assist. Having a separate environment for testing is always recommended (that way you can change variables without risk of hurting the live site).

    And just to make sure, you've opened a ticket for the developers of Advanced Access Manager? They'd be the best source for getting this sorted.

    Thanks.

  • aecnu

    Greetings mmedia,

    It appears this particular topic is now resolved/closed, if you need any further assistance please let us know.

    If it wasn't resolved, or you have any more questions related to this thread, please feel free to post them below including any new symptoms or errors and tick the 'Mark as Not Resolved (re-open)' box below the post area (or else we'll miss it!)

    Thank you for being a WPMU Dev member!

    Cheers, Joe :slight_smile:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.