Cookieless domain setup

Multisite Cookieless Domain

I'm wondering if it's possible to set this up? I've tried to follow several guides but it just doesn't seem to work on multisite installation. Anyone have any luck on multisite with this?

This is the guide I followed
https://www.itsupportguides.com/wordpress/wordpress-how-to-serve-static-content-from-a-cookieless-domain/

  • Joshua
    • The Incredible Code Injector

    So I got it working on a single install, but for some reason when I'm trying to log into my network dashboard, it's redirecting me to re-log in and I can't access the page. This doesn't happen in a single installation.

    this is my .htaccess file

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    this is my wp-config information

    // Static Content //
    define("WP_CONTENT_URL", "http://static.artofwargaming.net");
    define("COOKIE_DOMAIN", "www.artofwargaming.net");
    define("WP_PLUGIN_URL", "http://static.artofwargaming.net/plugins/");
    //End Static Content//
  • Nithin
    • Support Wizard

    Hi Joshua,

    Hope you are doing good today. :slight_smile:

    Cookieless domain configuration as mentioned in the tutorial, will be the same for multisite. There shouldn't be any other extra steps to perform this, are you using Domain Mapping plugin? There could be a conflict.

    However when I try to load your static domain, I'm getting the 403 Error Forbidden. Could you please check whether this is the case. Since your website is in maintenance mode, could you also enable support access, so that we could give a closer look. You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please let us know once you enable access. Have a nice weekend. :slight_smile:

    Kind Regards,
    Nithin

    • Joshua
      • The Incredible Code Injector

      Hi Nithin

      I've enabled support access. I had to do a total overhaul of my website and it is ready now. I've got the multisite set up with one subdomain. Unfortunately, I can't log into the subdomain admin dashboard because it says I need to enable cookies on the domain.

      Thanks for your help on this.

  • Joshua
    • The Incredible Code Injector

    Just wanted to update this. I have sense removed the define from my WP-CONFIG file as was suggested in a Stack Overflow article and the cookies across the multisite work properly and the subdomain I set up as "cookieless" remain cookieless.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.