Correctly Formatting Date in the Upfront "Posts" Element

Hi!

I am trying to format the date of a post correctly inside the Upfront Posts element. When the post is displayed in the box that WordPress natively produces, the date of the post follows the correct format that I specified in the WordPress option, even though it is not in the correct place and I can't seem the change that up with Upfront. So, I added a "Post" Upfront element to the page and moved the date where I wanted it, but that date seems not to respect my date formatting setting in WordPress. See the screenshot for the two ways the date is displayed for the same post. The bottom is the date in the WordPress post window. The top is the date in the Upfront Post element, which has some very strange formatting. How do I correctly format the date in the Upfront Post element?

Thanks!

  • Vinod Dalvi
    • WP Unicorn

    Hi Heath,

    I hope you are well today and thank you for your question.

    When the post is displayed in the box that WordPress natively produces, the date of the post follows the correct format that I specified in the WordPress option, even though it is not in the correct place and I can't seem the change that up with Upfront

    Could you please tell me what exactly you meant by box and share the page URL where it's displaying and tell me where you want to show it so that i can help you to correct its place?

    So, I added a "Post" Upfront element to the page and moved the date where I wanted it, but that date seems not to respect my date formatting setting in WordPress.

    You can edit the Post Parts of the "Post" Upfront element and configure the date formatting as displayed in the attached screenshot.

    Best Regards,
    Vinod Dalvi

  • Heath
    • Flash Drive

    Vinod,

    Okay. Thank you. I am trying to work with that now, so I am trying to learn the codes that go in that. If I want to the date to be displayed as "MONTH, DAY, YEAR" like "May 13, 2015" then should put F j, Y in that window, right? I don't care about the time. Then, in the HTML code in the window I put:

    <div class="uposts-part date_posted">
    Posted on <span class="date">{{date_1}}</span></div>

    I must be missing something, because when I have put that. All I see is "Posted on May" with no day or year.

    This is the page I am trying to work with: http://www.rainnstudios.com/war-of-kings-retrospective/

    I'll post that link the other ticket I have open where I'm trying get my blog post page set up.

    Thank you for your help!
    Heath

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.