"Could not remove the old plugin."

Hi folks,

Whenever I try to update any WMPUdev themes or plugins I seem to get the message "update failed. Could not remove the old plugin". This only seems to happen to WPMU plugins.

Any ideas how I can solve this?

Thanks,

Dave