Coupon Code not working, redirect to initial signup page and registers user as inactive user

On registration page, a user clicks sign up -> then are directed to page to register credentials then user clicks submit -> user is directed to payment page, they are also given the option to add a coupon code -> when user submits code they are redirected to begining of process (the page with the signup button)

I have it enabled in membership -> extras.

Thanks in advance for the help.

  • Patrick
    • Support Monkey

    Hiya @jonathan_sabin

    I think you may be confusing “Invite Codes” and “Coupons”.

    The invite codes must be defined and enabled under “Extras” but only apply to the registration process.

    Coupons are defined under the “Coupons” menu item and are used to give discounts when paying for a subscription.

  • pete_lower
    • Flash Drive


    We are not trying to use Invite Codes because they require a user to have an invite code.

    We want to give people the ability to come to the site and use a coupon code we gave them to purchase a login for a discounted or free price to promo the product.

    Specifically, We will be selling a profile/test/ subscription to team coaches.

    Next we next to assign 10-50 codes for the players to take the profile/test.

    Is there a better methodology?

    From our side, we are deeply disappointed that the coupon issue has remained unresolved for for over 6 weeks?

    When can we expect a usable,debugged resolution?

    The client is furious with us, actually they should be furious with you.

    Is there a number I can talk to a human about this?

    May we work towards a WIN_WIN situation for all parties involved?

    Can I count on your firm to deliver?

    Thank you for your consideration.

    Jonathan Sabin


    Vortex Business Solutions

    Pete Lower

    Senior Development Engineer

  • pete_lower
    • Flash Drive


    May I send you screen shots…?

    We Really need to get this resolved.

    Entering code and see what happens…

    Is there something wrong with the coupon programing or our post coupon programing?

    It returns to the same screen and then you can’t login at all…

    This issue was 1st reported on December 17, 2012.

    You have created a very embarrassing situation for my firm.

    We have so much programming invested, however the system doesn’t work.

    What do I need to do to get resolution?

    The sign of an exceptional company is how they deal with exceptions.

    Did you know that an unhappy customer tells 19 people, whereas a happy customer tells 5. with modern social media, these numbers are multiplied by 100’s and 1000’s.

    I would be very happy if you would help us resolve this issue…

    Jonathan Sabin


    Vortex Business Solutions

  • Patrick
    • Support Monkey

    Hi again @pete_lower

    The sign of an exceptional company is how they deal with exceptions.

    You’re absolutely right on that point, and I apologize for the response delay. We’re busy as beavers on forums these days and, unfortunately, some threads tend to fall through the cracks.

    But we’d love to help you resolve this issue, so here’s what I propose if you agree:

    Use the contact form on the following page to email me admin login credentials, and I’ll take a look behind the scenes tomorrow evening, say around 7pm Eastern:

    If that is agreeable, please mark the email to my attention, and include the following:

    Site URL: _______

    Admin username: ________

    Password: ____________

    Link to this forum thread: ___________

    Let’s get this donw shall we?


  • Patrick
    • Support Monkey

    I thought I had figured it out :slight_frown:

    You have things set up so a newly registered user is redirected to the “Welcome” page. But that page was not checked in the positive rule you had added to the access level of the subscription plan. But correcting that didn’t change anything unfortunately. Also tried setting the coupon to be valid for only the specific subscription. Didn’t help.

    This leads me to think that, with respect to redirection, there may be an issue with the template used for all those inner pages. Now, although I did view the template code via the editor feature under “Appearance”, I did not venture into studying the code in any depth (that is beyond the scope of the support we offer here). That would be a task that your developer could take on; checking all the conditionals and page/post IDs in there to make sure everything is kosher.

    I also noticed that you have several other plugins activated that may cause issues as they affect cache, robots.txt and rewrite rules. Please have your dev review settings etc for those plugins as well.

    The actual issue is not so much redirection or the coupon (which is successfully applied), rather it is that newly registered users are not assigned a subscription. Once a subscription is assigned manually via the backend, access is granted to whatever is set in the access rules.

    If your developer can rule out any interference with other plugins and/or scripts currently active on the site, then we can debug further. However, as a first step, I would recommend basic troubleshooting protocol before calling in your dev:

    Revert to the default Twenty-Eleven theme and deactivate all other plugins. Does the problem still occur? If yes, then something may be wonky in the plugin install :slight_smile:

    If the issue is no longer present, reactivate your theme. Does the issue re-appear? If yes, theme/template conflict.

    If the issue still does not re-appear, re-activate plugins one by one until it does and you find the conflicting plugin.

    Once we’ve zeroed in on whatever may be the cause of your issue, we’ll be better equipped to deal with it.

    Please let us know how you get on with this. And once again, rest assured, we are committed to helping you resolve what can sometimes be very tricky issues with complex plugins.

  • pete_lower
    • Flash Drive


    The developer reports:

    When using the default WordPress theme (2012), the membership plugin works fine.

    When using the parent theme (Responsive), the membership plugin works fine.

    When using the Responsive custom child theme the plugin fails.

    The child theme seems to be the problem.

    Do you have any advice as to what to check for in the child theme that could be creating this issue.

    Thanks for the help.

  • Tom Eagles
    • Syntax Hero

    Hiya, just going through some of the older threads here.

    As it’s been a little while since we last heard from you I thought I’d check in to see how you’re going?

    If you’re still looking for some further assistance with this thread then please feel free to reopen the thread or of course for any new and related issues you are most welcome to open a new thread.



  • Smart Site 4u
    • Design Lord, Child of Thor

    Hello Everyone,

    I just came across this topic (yes I know it’s half a year old) and I am having the exact same issue. Should I create a new topic?

    Does anyone know if @pete_lower every solved this problem?

    I am going to try the troubleshooting tips above and will see how it goes. Everything was fine until we updated to the latest version of WordPress.

    We have a WordPress Multi-site install and we are using your Membership plugin (RC Version), BuddyPress and more of your plugins.

  • Patrick
    • Support Monkey

    Hi @Onlinemall

    This issue was never resolved. But, as you can see by the progress in the thread, it turned out that the problem was caused by a custom child-theme of the Responsive theme.

    If you are using a custom child-theme of Responsive, then yes, your issue may be related and the discussion could continue here.

    But as it is many months old, and the Membership plugin has gone through multiple updates in the meantime, it would be preferable to begin a new thread to report your issue.


Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.