Course Draft mode and Live mode problem

Hi,

After making a Live mode course into Draft mode, the View Course, View Units links direct to 404 page not found. Before making the draft course into Live, View course link direct to the Private Course page. It no longer works after making the Live Course into Draft mode again.

Can someone please look into this?
Thanks.

  • Nastia
    • Support Rock Star

    Hello @plentylandonline

    I can't replicate the same on my installation.

    Would you please run a quick check for a conflict with a plugin/theme?

    Deactivate all other plugins and test again. If the issue is gone, please activate one plugin at the time to find out which one is causing this conflict.

    Please follow the flowchart from our manual:
    https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Would you be able to grant us support access so we can take a closer look?

    You can grant support access via admin dashboard - WPMU DEV > Support
    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Let us know how it went

    Cheers,
    Nastia

  • chathura
    • HummingBird

    This is hopeless. Its not a plugin conflict.

    Just try this simple steps.

    1. See draft mode View Course, View Units in a newly crated course. You'll notice 'Private' marked in the course title.
    2. Make it live.
    3. Make the course to draft mode again.
    4. Now try to View Course, View Units. You'll see those links direct to Page not found.

    I think this is a bug. I already raised an issue regarding UNIT live draft mode problem. I think this is continuation of that.
    Sorry, I'm tagging Michael Bissett here.

  • Nastia
    • Support Rock Star

    Hello @plentylandonline

    I've followed your instructions and I still cannot reproduce this on my installation. Would you please elaborate and let us know more details about how to reproduce it.

    Also, when you mention "See draft mode View Course.." you mean viewing the course page on the front end?
    Do you click on Units, before changing the course to Live and then back to Draft?

    I've tested this on the multisite installation with user administrator role. I'm sharing mysteps here with you. Please correct me, if you see me taking wrong steps to reproduce the issue.
    1. I've created a new course and a new unit, all as a draft
    2. Navigated from the dashboard to CoursePress > Courses
    3. Switched the course to Live and back to Draft
    4. Viewed the Course and Units by clicking on the links:
    - View Course
    - View Units

    I tested with the WordPress default theme and with the Coursepress theme.

    Both times the pages were opened and no 404 errors were shown.

    Do you use any specific options inside the course's settings? Would you please grant support access from your Dashboard > WPMU DEV > Support so that I can check?

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Cheers,
    Nastia

  • chathura
    • HummingBird

    Thanks for the detailed answer Nastia. Very sorry for my harsh words earlier. Had a rough day.

    Can you try it with a different user role, like instructor?

    Yes, View course direct to course page and View units direct to inside of the course (unit pages).

    Do you click on Units, before changing the course to Live and then back to Draft? I don't understand this. You just have to make toggle the Course Live draft mode only. Units toggle is a different issue.

    Yes, When created a course as Admin, The View links won't direct to 404 page not found.
    Even there, View Units link has a problem. It directs to the View course page (Course overview), not inside of the course. On the front end, Units tab also directs to the course overview page. Can you check this?

    * The UNIT draft mode Live mode I mentioned in a different thread also seems to work when use the plugin as Admin.

    Support access is granted. Don't do testing on my site! Do testing like settings changes in your own installation.
    Thanks.

  • Monica
    • Design Lord, Child of Thor

    chathura,
    I have the same problem regardless of what role I am logged in as, unless I make the course live I get a 404 when in draft mode, page can not be found. I have to make the course live to be able to see it which is not the ideal way to work on it so you are not the only one having this issue.

  • Panos
    • SLS

    Hello chathura,

    I have also tried out what you describe in your posts and can replicate this issue, I actually have noticed that this happens when logged in as administrator, though when logged in as instructor it still displays the Private course page. I have attached a file to replace in order to allow administrators to view these private courses. To replace please follow these steps:
    1. Download and unzip file at your desktop
    2. Connect to your site with ftp client (filezilla) or cPanel
    3. Replace file wp-content/plugins/coursepress/includes/admin-pages/settings-instructor-capabilities.php
    4. Go to admin menu > CoursePress Pro > Settings > Instructor Capabilities and click save.

    That should do it :slight_smile:

    As for your other issue about the draft units perhaps this post may help : https://premium.wpmudev.org/forums/topic/course-writing-issues-i-am-getting-units-not-showing-up-on-a-teachers-computer-and-preview-errors#post-1051542

    Hey @monica7,
    could you please confirm that you can't see private course even if your are logged in as an instructor? To do so, you can create a temporary instructor and then login with that account and create your new course. Set it to draft and try to open it in front end.

    Kind regards,
    Panos

  • Nastia
    • Support Rock Star

    Hello @plentylandonline

    You are right, I appologize for my mistake!

    I have confused the threads here. But I was able to replicate the issue with Course and Units lands on a 404 error page, like I said in the above post, and our developers have been informed about it.

    My sincerest apologies for this inconvinience! I assure you that this mistake will not happen again.

    Kind Regards,
    Nastia

  • chathura
    • HummingBird

    I'm sorry for my behavior toward you as well. Its just, I get really annoyed when people don't provide a concrete answer to a simple question. May be I should've explained the question better. I'll try to do that next time when I try to submit a ticket.

    Thanks for being patient with your customer :slight_smile:

  • Nastia
    • Support Rock Star

    Hello @plentylandonline

    Don't worry about it :slight_smile:

    We absolutely understand your frustration. We will also try harder to analyze each step, so we could be able to reproduce an issue much faster.

    And thank you for your patience and persistence with us :slight_smile:

    Kind Regards,
    Nastia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.