Course Unit Re-Ordering Not Working

Hi, I have tried numerous times by drag and drop to place the unit entitled CPPFES2020A, above the one entitled CPPFES2026A, but each time I come back to the page, it has repositioned itself again.

  • Sajid
    • DEV MAN’s Sidekick

    Hi @rogera,

    Hope you are doing good today :slight_smile:

    I can see the re-ordering is working fine on your website. I could successfully swap last two units with each other as seen in attached screenshot. The changes reflect on front-end too (I have reverted back to where it was after testing).

    Make sure you drag and drop the units when page is fully loaded. Feel free to post a reply if you need further assistance.

    Take care and have a nice day :slight_smile:
    Cheers, Sajid

  • Tyler Postle
    • CGO

    Hey Roger,

    I'm not able to login to your site, it's giving me a server 500 error. I asked one of my colleagues to try as well and he got the same issue. You could try revoking and regranting, but if this is a server side issue then that likely won't make a difference.

    To make sure we don't need to ask this again, could you send in the wp-admin credentials?

    You can send that privately through our contact form: https://premium.wpmudev.org/contact/

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me.

    Send in:

    Subject: "Attn: Tyler Postle"
    -WordPress admin username
    -WordPress admin password
    -login url
    -link back to this thread for reference
    -any other relevant urls

    I tested your issue in my own install and it's saving correctly. Given that you have a lot of units, I'm wondering if this could be an issue with your max_input_vars. If you're having other issues with content not saving properly then it probably does.

    In that case, you will want to add this to your .htaccess:

    <IfModule mod_php5.c>
    php_value max_input_vars 9999
    </IfModule>

    If the above issue still exists after that then please send in the credentials as mentioned above and I'll have a closer look :slight_smile:

    Cheers,
    Tyler

  • Tyler Postle
    • CGO

    Hey Roger,

    Thanks for doing that. I can login through the support access now too, awesome.

    I tested out swapping around units with the first two and it worked for me as well. I navigated to the Media Library after and then back to the course and the changes remained. I then switched it back. I did this a couple times just to make sure.

    Is the issue still happening for you?

    I see you already have a max input vars defined in your php.ini. So perhaps that already resolved the issue?

    Look forward to hearing back!

    Cheers,
    Tyler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.