Course Units page description offset

In my courses units page the saved description is very offset, I've attached a screenshot to show what i'm talking about. Hoping to get help fixing that and I also have a second question regarding the units page.

The units page has a huge list of all the units but they aren't clickable to jump to the unit. One, is there a way to make them all clickable to go to that unit and two, is there a way to add styling to the list. Just something simple like bullet points? I've also attached a screenshot of the units list for reference.

I've also enable support in case needed.

Thanks in advance for all your help.

  • Brian

    Additionally I am having issues with the plugin saving settings. This setting, in units, "User needs to answer all required assessments and view all pages in order to access the next unit" can be checked and unchecked but I still get this response when navigating to next units

    "You need to complete all the REQUIRED modules before this module.

    Please press the Prev button on the left to continue."

  • Rupok

    Hi Brian,

    So sorry to hear the inconvenience you are having. I'm afraid, the screenshots didn't come with your reply. Can you please send them so we can get a better idea about the issues you are having?

    CoursePress units are clickable in front-end. Please check the attached screenshot for reference.

    So I'm not sure why your site is not showing them as clickable on your site. I could tell you better after checking your site configuration.

    To check the module progressing issue, I again need to see your current configuration. To check your setup, I tried to login with Support Access, but it's showing me the following error:
    Sorry, this is an invalid access token. You must ask the user to grant access.
    Can you please revoke and grant us permission once again so we can investigate the issue on your site and try to fix these as soon as we can?

    I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • Ivan

    Hello Brian !

    I tested this issue with default theme and it works fine. It seems this issue happens only your current theme. You can try to add this code via FTP or SFTP to (wordpress_folder)/wp-content/themes/flatsome/functions.php file.

    function wpmu_wrap_the_excerpt( $content ) {
        if ( !empty( $content ) ) {
            $content = '<div class="row">' . $content . '</div>';
        }
        return $content;
    }
    add_filter( 'the_excerpt', 'wpmu_wrap_the_excerpt' );

    For example, add this code to end of the file to this place

    Best regards,
    Ivan.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.