Course writing issues- I am getting units not showing up on a teacher's computer and preview er

I was on Zoom today with a teacher sharing her screen. We went to her course and she though she had created two practice units for a course that is live for signing up, but as soon as she would save the units they would disappear. She tried to create a unit while I was there, and as soon as she saved it , it again disappeared from her monitor. You can see this as units.jpg
So I logged on and went to her course, and all the units she had attempted to save were there.
I had her clear her browser cache, log out and log back in to http://www.spirit-edu.com/learn.
Still nothing.
I upgraded her privileges to admin from editor (with teacher privileges) which I didn't really want to do, and all the units were showing on her monitor. When we went to preview we got the error message, in image capture code.jpg. At that point I couldn't do anything with her. I clicked on "view units in the tabs and it shows (Capture3.jpg) error messages for all three units she created.
Additionally, when I tried to log out of spirit-edu.com/learn from the dash ribbon on the far right, it kicked me upstairs to spirit-edu.com which is a separate wordpress install, and it never logged me back out.
I don't know why she had to be upgraded to admin and I don't want that, but I also expect that she should be able to see the units she is creating.
At one point when we clicked on the units tab while in course overview, the overview tab disappeared altogether.
Her browser is Chrome and mine is Firefox. Most of her issues were when she had editor status, but neither of us can preview what she has added which is basically an image and a title.
I am granting access to the back end.

  • Nastia

    Hello @jtstarke

    I trust you are doing well today!

    To hide the warnings, please open the wp-config.php file, locate the following line:
    define( 'WP_DEBUG', true );
    and change it to this:
    define( 'WP_DEBUG', false );

    I can't replicate the same issue on my sandbox installation. I can confirm though, that the units are not shown for the Editor user role on your installation. Also there is a JS errors in the developer console:

    Uncaught TypeError: Cannot read property 'fire' of undefined

    Would you please run a quick check for a conflict with a plugins?

    Deactivate all other plugins and test again. If the issue is gone, please activate one plugin at the time to find out which one is causing this conflict.

    Please follow the flowchart from our manual:
    https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Let us know how it goes!

    Cheers,
    Nastia

  • jtstarke

    Nastia,

    You say, "I can confirm though, that the units are not shown for the Editor user role on your installation".
    How would I change the editor role to allow for that, and why would it be unique to "MY" installation?
    I added only one plug in since the last time I was asked to disable all my plugins and deleted it yesterday when I was in communication with my instructor. I will do it again, but are we doing this to check js script errors, or units not showing up as an editor, which you indicated was a "User Role" issue?
    What is the line that is missing in the "editor" role that would allow an editor to see and modify units?

  • jtstarke

    OK. I checked my wp config file, even though I thought I had already changed the true to false. I have disabled all the plugins except CP, MP and the WPMU Dash.

    I am still getting the [Capture_code.JPG ] error and the units still disappear for an editor. (See course named "jim" . 2 units were made but only visible to admins.

    I shouldn't have to give admin prileges to teachers, and have one that is or was an editor and can create and see, at least last fall. The only changes to the site were plugin upgrades Core WP upgrades and WPMU plugin upgrades.

    When you pay $588 a year for basically 2 plugins, as a customer, they should work without having to constantly tweak, code, and otherwise work on it. That's why I am using WordPress and your plugins, so I can concentrate on the business and teaching and not the development. I said this a year ago, I feel like I'm beta-testing your software and paying for the privilege. NOT!

    Definitely not worth a lifetime membership.

  • jtstarke

    In case you ask, I have a VPS server, linux based, and if you check my past coursepress posts, you'll know the answers to most of the rest of the questions you're going to ask.

    So, I need the Editor/teachers to be able to build courses and I need the rest of the warning messages to go away.

    It does not make sense that a teacher with editor privileges can create a unit, but then when it's saved, it disappears from view and cannot be seen without admin privileges, and it does not make sense to give all my teachers admin privileges allowing them full access to the site.

  • Panos

    Hello @jtstarke,

    Thank you for providing access to your site. I managed to log in successfully and here is what I have noticed.

    The Warning message, which now should be hidden thanks to setting, 'WP_DEBUG' to false, is shown when you are viewing a Unit which has not been set to 'Live'

    For the same reason an instructor may not be able to see the units as in your description. If the instructor has checked the "Live" option then the unit should not disappear.

    I can't be sure if this is by design or not, I will ask the developer and when I have an answer I will post another reply.

    Hope this helped!

    Kind regards,
    Panos

  • jtstarke

    Hi,
    First of all, I did not set debug to false during this issue. I did it a year ago, with other issues I had with CP Pro, so that is not the reason the warnings don't show any longer, it's because all my other plugins are disabled making the rest of the functionality of the site useless.

    Second, I never had to have the units be "Live" in the past for a teacher with editor privileges to access and see the units they prepared as they all had only "editor" privileges previously.

    Third, this takes away the ability of the teachers to work on the units and create and edit units without making the units available to the students until the actual date of entry into the class. This is not acceptable.

    I hope you will have a fix for this soon. I would like to hear from someone more knowledgeable on this platform, like maybe one of the developers.

    Last year I said I felt like I was paying $268 to be a beta-tester of this plugin that broke fairly regularly, and now this year I feel like I'm a beta-tester paying $588 to help you develop a stable platform, which this is not.

  • Panos

    Hello jtstarke,

    I'm sorry you feel this way. I have already flagged it as a bug so the developers will work on solving it.

    Until then I have attached you an unofficial version of the plugin that fixes this issue, which you can use.

    Edit:
    It seems the attachment could not be uploaded due to it's size. You can download it from here: https://www.dropbox.com/s/xp7znfzlagavdh8/coursepress.zip?dl=0

    Apologies for any inconvenience and thank you for your patience!

    Kind regards,
    Panos