CoursePress and Membership 2 shortcodes issues

When these shortcodes are on the same page [ms-membership-account] AND [courses-student-dashboard], I get a PHP warning “Header already sent”. Only the forms and a white page is displayed.

  • Predrag Dubajic
    • Support

    Hi stripedrhino,

    Hope you’re doing well.

    I was doing some tests based on your chat but I’m afraid that I can’t replicate the issue on my site when I use [ms-membership-account] and [courses_student_dashboard] shortcodes on the same page.

    And also, when I check your test-site.com/account/ I don’t see a blank page, I see both enrolled courses and account information properly.

    Can you tell me if I’m missing something here or perhaps some steps that I could follow to replicate this issue?

    Best regards,

    Predrag

  • Predrag Dubajic
    • Support

    Hi stripedrhino,

    Thanks for the additional info and sorry I missed this at the first, it looks like the issue is with [courses_student_dashboard] shortcode being used in a page that is selected as default Membership 2 page.

    I have created a bug report and forwarded it to our developers so they can check what’s going on here.

    Best regards,

    Predrag

  • Adam Czajczyk
    • Support Gorilla

    Hi stripedrhino

    I hope you’re well today and I apologize for the delay.

    We just talked to our developers and I’ve attached a zip file to this post. Please download it and upload the “cpm2-shortcode-patch.php” file form inside attached zip archive to the

    /wp-content/mu-plugins

    folder on your server; if there’s no “mu-plugins” folder inside “wp-content”, just create empty one.

    Would you please give it a try and let me know if this works for you?

    Best regards,

    Adam

  • stripedrhino
    • Site Builder, Child of Zeus

    Adam Czajczyk,

    Thanks man! This showed the form and I was able to trigger the reset password email for my test user.

    It’s doing some weird stuff though in that it’s forced the /lost-password/ page to show as a sub-page underneath my /dashboard/ page. Which obviously requires the user to log in to see the content, so there is a pw reset form just above a login form. Looks like /lost-password/ is created on the fly as I can’t edit it in my Pages area… any way for me to change it?

    Thanks again.

  • Adam Czajczyk
    • Support Gorilla

    Hey stripedrhino

    Good to know that it worked, at least partially :slight_smile: I’m not sure though why the issue with “lost password” is happening. I understand that it happens ONLY with that patch applied, correct?

    Could you enable support access to the site so I could take a look at this? You can do this on “WPMU DEV -> Support” page in your site’s back-end, by clicking on “Grant support accesss” button.

    It would be also great if you could (just to make sure) give me a short step-by-step guide on how I would replicate that on your site.

    Best regards,

    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.