[COURSEPRESS] Course does now show in WooCommerce shop

Course does not show in WooCommerce shop and when adding manually to cart it does not show there either.

  • Nithin
    • Support Wizard

    Hi Kayla,

    Hope you are doing good today. :slight_smile:

    I could notice the issue in your website, however I tested this in my system, but wasn’t able to replicate. I could notice 500 error in the console, and this needs further troubleshooting.

    Seems like you haven’t shared FTP login credentials with us, in order for us to check how the site behaves once debug mode is enabled. Could you please enable debug mode in your system, and share the error logs, so that we could have a better idea.

    To enable debug mode, open your wp-config.php file located in your root directory, and look for define(‘WP_DEBUG’, false);. Change it to:

    define('WP_DEBUG', true);

    In order to enable the error logging to a file on the server you need to add:

    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );
    define( 'SCRIPT_DEBUG', true );

    After making the above changes, please try to replicate the issue again. Once done, the errors will be saved to a debug.log log file inside the /wp-content/ directory.

    Please attach these in your next reply in txt format file, so that we could give a closer look. You can find more details about debugging here.

    If you aren’t sure how to enable debug mode as mentioned above, you can send credentials by using our secure contact form: https://premium.wpmudev.org/contact/#i-have-a-different-question

    – To Mark to my attention, the subject line should contain only: ATTN: Nithin Ramdas

    -FTP credentials (host/username/password)

    -link back to this thread for reference

    -any other relevant urls

    Please do follow up in the ticket once you have sent the above credentials. Have a nice day. :slight_smile:

    Kind Regards,

    Nithin

  • Nithin
    • Support Wizard

    Hi Kayla,

    I’m not showing an email on my side, can you please resend?

    That’s odd, you should have received the email. Maybe it’s in spam? I have sent email asking for the Godaddy login.

    If you still don’t see the email. Please share the login by using our secure contact form: https://premium.wpmudev.org/contact/#i-have-a-different-question

    – To Mark to my attention, the subject line should contain only: ATTN: Nithin Ramdas

    -Godaddy Account Loign (Login URL/username/password)

    -link back to this thread for reference

    -any other relevant urls

    Please do follow up in the ticket once you have sent the above credentials. Have a nice day. :slight_smile:

    Kind Regards,

    Nithin

  • Nithin
    • Support Wizard

    Hey Kayla,

    Hope you are doing good today. :slight_smile:

    Sorry for the delay in getting back to you, I troubleshooted this issue further, and could notice that the following error is getting generated in the logs:

    Fatal error:  Uncaught Error: Call to a member function get_image() on boolean in /wp-content/plugins/woocommerce/includes/abstracts/abstract-wc-product.php:1828
    Stack trace:

    On giving a closer look, this seems to be more related to a bug in WooCommerce side. I checked the WooCommerce bug reports, and could notice they have a fix ready in the next version.

    I have already applied the fix in your website, by replacing the following attached file, under:

    /wp-content/woocommerce/includes/abstracts/abstract-wc-product.php

    And now, he Products, and Carts page seems to load fine in your website. Please check ,and see whether it’s working fine in your side, and please let us know if you have any further query.

    Have a nice day ahead. :slight_smile:

    Regards,

    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.