CoursePress hangs on Edit Course page with save Draft on each step

May be a mistaken post, I'm not using the Pro version...
I am trying out CoursePress on a subsite in a MultiSite I use for testing out plugins http://toni-esl.com/sitetest/.

I am trying to create a course on the Edit Course page in settings.
Each time I complete a step and hit "Draft" the page reloads okay, but there is a spinning icon next to the Draft button. It hangs. I have to manually reload the page, then I go continue to the next step.

Am I doing something wrong?

  • Predrag Dubajic
    • Support

    Hi Toni,

    Hope you're well :slight_smile:

    It doesn't sound like you're doing anything wrong, it seems like there's some JS error on your site, perhaps plugin or theme conflict but I would like to have a look first if you don't mind allowing support access to site in question?
    To enable support access you can follow this guide here:
    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Please respond in this thread once access is granted.

    Best regards,
    Predrag

  • Adam Czajczyk
    • Support Gorilla

    Hello Toni,

    Thank you for enabling support access.

    I checked the site and I see that htting "next" in a section or hitting "Save Draft" button, they both seem to be working as expected in that sense that they save changes and switch settings to the next section. I can fully confirm the "spinning wheel" issue though.

    However, I didn't see any errors in browser console or any other kind of warnings or "weird behavior" so I think that means that after all the conflict test would be necessary here.

    Basically, a conflict test means switching off all the plugins except CoursePress and swtiching the site to Twenty Sixteen or Twenty Seventeen theme and then testing if the issue happens again. If not, you'd want to enable theme and plugins back one by one each time checking for the issue. Take a look at this flowchart please:

    https://premium.wpmudev.org/wp-content/uploads/2015/09/Support-Process-Support-Process.gif

    Could you please perform such test? Let us know about its results, hopefully that should give us a better insight on what's happening there.

    Best regards,
    Adam

    • Toni Hoskin
      • Recruit

      I'm curious to see the flow chart, great idea!

      The plug-in does work, no errors, I simply have to manually reload the page - so I thought I wasn't doing things in the correct order. I will have to disable network plug-ins - except Jetpack. I've had issues in the past reconnecting Jetpack because of my hosting security so I'd rather not mess with it.

      After some thought, I will try a different LMS. I create separate sites to prevent plug-in conflicts. If there is a conflict it is with a network enabled plug-in. That is a bad start.

      Thank you!

  • Predrag Dubajic
    • Support

    Hi Toni,

    If you have staging site you can perform the conflict test there and once we pinpoint the cause (troubling plugin or theme) we can debug it further from there and see if there's something that can be changed from our end to have this working on your installation.

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.