CoursePress is Running Slower and Slower

My site running CoursePress has always been extremely slow (astepx.com). Over the past few days it has become too slow to even work on. I have tried so many things like Hummingbird, WP Super Cache, etc. but have gotten no results. You have insisted it's and issue with my host Media Temple and they insist it is a problem with the plugin. My most recent Hummingbird score was 39. There are many things I like about CoursePress but this has to be resolved. Can I please speak with someone or live chat on the issue? I've been trying to get this fixed for a very long time.

  • Sajid

    Hi Matthew,
    Hope you are doing good today :slight_smile:

    Did you check your site performance after deactivating the CoursePress plugin ? I am asking this because its working fine for me on my own website. The hummingbird score is 69-74 for me while its installed and active.

    You can see what exact plugin and where exactly its consuming the resources by using P3 Plugin profiler plugin.

    If you could grant support staff access, then I can take a closer look myself. You can grant access from WPMU DEV > Support > Support Access > Grant Access or see this manual.

    Take care and have a nice day :slight_smile:
    Cheers, Sajid

  • Matthew

    Thanks for your response, Sajid. I have tried most of your suggestions. Yes, I have deactivated the plugin and seen improvements. I've also installed WP Super Cache and other plugins to help the situation. Sometimes it will get a bit faster been then very slow again. I host this and many sites with Media Temple. I have no issues with my other sites. The issue consistently seems to be with the parsing of JavaScript.

    I have granted support access. Thanks so much for looking into this.

    Matt

  • Nastia

    Hello Matt, I trust you are doing well today!

    Would you please update the CoursePress plugin and try again?

    I can confirm that the page is loading very slow. Based from the P3 profiler the CoursePress does load mor ethen any other plugin, but still the loading time it;s les then a seconf ~ 0.5 sec.

    Try deactivating all plugins. If that resolves the issue, reactivate each one individually until you find the cause.

    If that does not resolve the issue, try switching to the Twenty Fifteen theme to rule-out a theme-specific issue.

    I can see that you are using Hummingbird with WP Super Minify. Using minification plugins at the same time may cause some issues on your installation. We suggest to use only one of them.

    Let us know how it went!

    Kind Regards,
    Nastia