CoursePress not working well on WP Engine

Can’t add instructors into the course and the Settings tabs do not load.

  • Nastia
    • Support Rock Star

    Hello morfjord

    Hope all is well!

    I could not reproduce this issue on WP Engine server on my end. Would you please make sure there is no conflict with the active theme on your site?

    Please switch to a default WordPress theme, Twenty Seventeen and see if the issue still persists.

    If the issue still persists, please send to us your credentials. You can send credentials by using our secure contact form

    https://premium.wpmudev.org/contact/#i-have-a-different-question

    Subject: “Attn: Nastia”

    – WordPress admin username

    – WordPress admin password

    – Login URL

    – FTP credentials (host/username/password)

    – Link back to this thread for reference

    – Any other relevant URLs

    Looking forward to your reply!

    Kind regards,

    Nastia

  • Nastia
    • Support Rock Star

    Hello morfjord

    Hope you’re doing well!

    Thank you for sharing your credentials. Please let me know if you have deactivated the theme to make sure this is not a conflict with another theme?

    Please clarify, the credentials you’ve sent are for the development copy of your site? Can we access it and troubleshoot the issue?

    I am afraid we missing some credentials to start the test, please send in your WordPress admin’s username and password using our contact form:

    https://premium.wpmudev.org/contact/#i-have-a-different-question

    Subject: “Attn: Nastia”

    – WordPress admin username

    – WordPress admin password

    – Login URL

    – Link back to this thread for reference

    Looking forward to your email.

    Kind regards,

    Nastia

  • Nastia
    • Support Rock Star

    Hello morfjord

    Hope you’re well!

    The CoursePress is working well with PHP version 7.0 and higher. Please enable debug. mode and add the following lines in the wp-config.php file:

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );

    Please make sure that you insert these lines above /* That’s all, stop editing! Happy blogging. */ . Try to replicate the issue, this way all errors will be saved in the debug.log file inside the /wp-content/ directory. Let us know if you will see any errors there.

    Please advise,

    Kind regards,

    Nastia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.