CoursePress Preview Not Working

Hi, the "Preview" feature for the Units is not working on my site. When I click on the "Preview" link, it just reloads the page (https://www.stevefarber.com/ecourse/courses/the-extreme-leadership-edge/).

Screenshot: http://take.ms/AQO1M

I've tried flushing the permalink, didn't help. I also tried plugin conflict test, that didn't help either.

I've provided all login credentials in chat. Can you please check the issue for me?

  • James Morris

    Hello David,

    I hope you are well today. I'll be following up with you about this issue.

    I've gone through your site and checking out your settings. A symptom I'm seeing is that Administrators are able to access previews, but Subscribers and non-logged-in users are not. Doing a little more digging, I see you're currently running Version 2.0.7 of the plugin. The current version is 2.1.0.1.

    There's been a number of improvements and fixes since the version currently installed on your site. In the interest of ensuring we're not trying to troubleshoot an issue that's already been addressed by a previous update, would you please perform a full backup of your site and update the plugin to the latest version. Then, once that's done, retest and see if the issue persists. If it does, please let us know. We'll be happy to dig into this issue further for you.

    Best regards,

    James Morris

  • Ivan

    Hi David !

    I noticed that your site doesn't have changes provided in the patch. I added it on your site, also, I checked settings for showing course structure (WP Dashboard -> Coursepress Pro -> (choose your course) -> Step 2 – Course Details -> Course Structure section -> checkboxes for Show Free and Preview option ). I selected them again. And now, you should go to your CloudFlare account and reset cache for this site. It should help.

    Best regards,
    Ivan.

  • David

    So I tested the previews again after clearing the cloudflare cache'. It's still just refreshing the page instead of showing the preview. The page previews do seem to be showing up better now in the table of contents list on the course details page. So that's encouraging. But it's still doing the main issue, which is that it just refreshes the page and doesn't take you to a preview of the page.

  • Ivan

    Hi David !

    It looks like a bug in our CoursePress theme. I fixed it on your site and hit "Purge all cache" on /wp-admin/admin.php?page=wpengine-common page and, it seems, it works fine now. If you have the same issue on another site - you can add attached file as {wordpress_folder}/wp-content/themes/{your_child_theme}/single-unit.php file via FTP.

    Also, I'll ping our developers to fix it as soon as possible.

    Best regards,
    Ivan.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.