CoursePress Pro 2.0 more bugs

I have found more bugs, here they are

1- When we click "next" in the unity it doesn´t go to the top of the next page, but to the bottom.. Students have to scroll up for starting the unity.

2 - The Preview option doesn´t go to the exactly place we are in the unity, but to its begining, in this way, we have to keep clicking next next next until to reach the page we are editing.

3- Attaching image: there is something strange, when we select "attached page", it doesnt work, it opens the full image and not the theme style, however when we return, and click again, it works just fine.

Thanks

  • Rupok

    Hi Everaldo,

    When we click "next" in the unity it doesn´t go to the top of the next page, but to the bottom

    Do you mean this Themeforest theme by mentioning Unity? https://themeforest.net/item/unity-wordpress-crowdfunding-theme/10773175

    I just checked in my test site with default Twenty Twelve WordPress theme and I could not regenerate this issue. When I click next, the next page shows from the top. So I think this is your theme specific issue. Can you please try activating any default WordPress theme and check if the issue is there? If not, then surely this is related to your current Unity theme. In that case, can you please contact your theme developer regarding this? They can give you best idea as they have coded the theme. As this is a third party paid theme, I'm afraid, I don't have much idea regarding their coding and architecture. Please let us know what theme developer says about this. If there is anything to do from our end, we will be glad to do that.

    2 - The Preview option doesn´t go to the exactly place we are in the unity, but to its begining, in this way, we have to keep clicking next next next until to reach the page we are editing

    Can you please mention which Preview option you are referring to? Are you referring to the "Preview" button in each unit? If yes, then this is expected behavior. That preview button is shown at the beginning of your unit and at the bottom of your unit settings. So when you click that, it will take you to that unit page in front-end and the page should show from top. However, I think this will be nice if we have a preview button for each question so you can click on that preview button and it will scroll automatically to that question in front end. I'm moving your thread to our Features and Feedback section. More people liking this idea, more chances our developers will work on this and will include this feature in our future releases.

    3- Attaching image: there is something strange, when we select "attached page", it doesnt work, it opens the full image and not the theme style, however when we return, and click again, it works just fine

    I'm sorry but I'm not exactly sure which option you are referring to. Can you please provide a screenshot of that section so we become clear and can work on that? I can see that you have already granted Support Access. So we will jump in as soon as you send us details.

    Please let us know if I missed any point and send us as much details as you can. I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • Everaldo

    Hello Rupok!

    Thanks for the fast answer :slight_smile:

    1 - I will contact the theme people, however in the CoursePress Pro 1.0 I never had this problem... it started only with the 2.0 version, that´s why I was imagining it was some problem with the update.
    This is the theme i am using

    https://themeforest.net/item/foundry-multipurpose-multiconcept-wp-theme/12468676

    if you could give me some light on it, I would appreciate, it seems to be such a simple thing, but very annoying from the student´s perspective.

    2 - You are absolutely right, the preview goes to the beginning of the unity, however it would be nice if each step had its own "previews", that would avoid us to go every time to the beginning of the unity and keep hitting "next next next" until we reach where we are working on.

    3 - I am sending a link of a video of that issue. It is kind of complicated to explain. I guess that by video you will be able to see exactly what I am talking about.

    https://goo.gl/photos/KxievSDUncCXQacD6

    P.S don´t considere the music background ehehehh

    Thanks a lot,

    Everaldo

  • Kasia Swiderska

    Hello Everaldo,

    I'm sorry for the delay on our side. I could confirm those issues on your site however I could not replicate them on my site.
    My suspicion is that you theme is not playing well with new changes in CoursePress pro.
    Issue with loading next units not always on top of page and that lighbox doesn't fire instantly are in my opinion related. Lightbox works only when page is fully reloaded - so it has problems with pages that are using "smooth" ways to load content.
    I've send message to developers if its possible to turn off that way of reloading pages so it will behave like in old version of the plugin. I'm waiting for answer - its Christmas time so it can take a bit longer than usual to get feedback, so I really appreciate your patience here.

    kind regards,
    Kasia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.