CoursePress Pro 2.0 Question showing pendent

Hi there!

I am afraid I have found two more bugs!

1- When the student goes to "workbook" it shows a tick bullet for the correct answer (icon01.jpg), but when the student goes again inside the unity for checking the answer and to try it again if necessary, the icon shown is an X bullet (icon02.jpg) even if the answer is correct. I have also found that when the instructor will grade the students, all the correct answer come with a big red X icon, instead of a tick bullet (icon03.jpg). This big X is kind of misleading because visually we think it is a wrong answer....
* I have changed the theme and the problem persists.

2 - When questions are marked as "not avaliable" (pendent.jpg) it shows to the student on the workbook "pendent" (pendent02.jpg) as if the instructor would grade it, however for the Instructor It shows "not avaliable" (pendent03.jpg). Students kept asking why does it shows "pendent" if the question isn´t avaliable. I guess it is another little bug.
* * I have changed the theme and the problem persists.

I will await for this ticket to be 100% completed before I carry on looking deeply into the CoursePress Pro 2.0. I guess since it was updated I already have open several tickets with bugs, hope you guys are ok with that. I know that there are so many for the developers to check and small bugs are common

peace,

Everaldo

  • Predrag Dubajic

    Hey Everaldo,

    Hope you're doing well today :slight_smile:

    1- When the student goes to "workbook" it shows a tick bullet for the correct answer (icon01.jpg), but when the student goes again inside the unity for checking the answer and to try it again if necessary, the icon shown is an X bullet (icon02.jpg) even if the answer is correct. I have also found that when the instructor will grade the students, all the correct answer come with a big red X icon, instead of a tick bullet (icon03.jpg). This big X is kind of misleading because visually we think it is a wrong answer....

    Thanks for the detailed explanation, I was able to replicate this issue with CP theme and default WP theme so I've created bug report for this issue, both the back and front end.

    2 - When questions are marked as "not avaliable" (pendent.jpg) it shows to the student on the workbook "pendent" (pendent02.jpg) as if the instructor would grade it, however for the Instructor It shows "not avaliable" (pendent03.jpg). Students kept asking why does it shows "pendent" if the question isn´t avaliable. I guess it is another little bug.

    I was able to replicate this one as well so I have created another report.

    I guess since it was updated I already have open several tickets with bugs, hope you guys are ok with that. I know that there are so many for the developers to check and small bugs are common

    We appreciate this feedback a lot!
    Even though the plugin was tested in depth by multiple staff members and on different installations the plugin itself is huge and some things unfortunately go through unnoticed.

    We would appreciate if you can keep separate reports in separate threads, because our forum is configured to work in a way where only one bug can be reported per thread.
    Otherwise we need to create other reports manually which does take some time longer and having separate threads makes it easier for our developers to keep track of everything. :slight_smile:

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.