CoursePress Pro: Blank Screen on Unit Page

Hi--
I'm having trouble with CoursePress Pro + PageLines. I'm using PageLines to design the theme, and so far, it's working great with the WPMUDEV plugins I'm using. However, I've run into a problem with CoursePress Pro.

While the assignment and introduction (first unit) appear to be working, when I use a video unit, I get a blank page in both Firefox and Safari. However, it appears to be working in Chrome.

Any guesses as to what could be causing this?

  • Timothy Bowers
    • Chief Pigeon

    Hey there,

    I was just testing on my install with the normal themes (WP defaults) and that works ok for me.

    Just so I got this right, you're on the frontend and then you click on a video unit but get a blank page in Safari and Firefox?

    I tested in Safari on Mac and it was ok there.

    Can you please enable WP_DEBUG in your wp-config.php file?

    To output the WordPress debugging information you can open your wp-config.php file and change:

    define('WP_DEBUG', false);

    To:

    define('WP_DEBUG', true);

    You can also have these errors output to a debug.log file located in your /wp-content/ folder, to do this add the following to your wp-config.php file:

    define('WP_DEBUG_LOG', true);

    Using WP_DEBUG would put the errors on the site, you can hide those and just have them out put the WP_DEBUG_LOG (if set to true) by using this as well:

    define('WP_DEBUG_DISPLAY', false);

    Let me know what you find.

  • andrew
    • WPMU DEV Initiate

    OK, I figured it out, I think - I think it might have had to do with Membership settings.

    Now, I have a different problem. How do I turn off the redirect on login? No matter what, when my test user logs in, I'm directed to /courses-dashboard/. This occurs even if the user is not enrolled in the course.

  • Vinod Dalvi
    • WP Unicorn

    Hi @andrew,

    How do I turn off the redirect on login? No matter what, when my test user logs in, I'm directed to /courses-dashboard/.

    To turn it off try adding following code in the functions.php file of your child theme or add it in your site using any of the following plugins.

    http://wordpress.org/plugins/code-snippets/
    http://wordpress.org/plugins/add-actions-and-filters/

    global $coursepress;
    remove_filter( 'login_redirect', array( $coursepress, 'login_redirect' ) );

    Regards,
    Vinod Dalvi

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.