CoursePress Pro Bug: LOGIN_ADDRESS in email settings not using correct URL

When I have the "Use Custom Login Form" checkbox selected, a custom "Login Slug", and "Login Page" is set to "Use Virtual Page" in the general settings. But, I still receive http://domain.com/wp-login.php as the "LOGIN_ADDRESS" when I am creating the registration email.

  • Chris Chalmers

    I had the same problem and I see that the default 'STUDENT_DASHBOARD' shortcode in coursepress pro > email settings just leads to http://sitename/wp-admin. I had to replace manually with the url for student-dashboard (set in courspress pro > general settings).

    WPMUDEV Developers! - please look into this bug as it could cause a lot of confusion. Course registration email needs to point to the courses dashboard, not the general wp-admin dashboard where there is no mention of courses or anything like that.

  • Ash

    Hello Chris Chalmers

    Thanks a lot for reminding this issue. I am going to mark as a bug and reporting to the developer and also make sure that the developer check this ASAP.

    As a workaround, you can use this code, this way you don't have to make changes on every email content but use the original STUDENT_DASHBOARD shortcode. The code is:

    add_filter( 'coursepress_site_vars', function( $vars ) {
    	$vars['STUDENT_DASHBOARD'] == 'YOUR DASHBOARD URL';
    	return $vars;
    } );

    You can use this code in your child theme's functions.php if the theme is not changed. Otherwise mu-plugin is the best option. To create a mu-plugin, go to wp-content/mu-plugins folder. If there is no mu-plugins folder then, create one. Now, inside the mu-plugins folder create file with name anything.php (make sure file extension is .php). Now start with a <?php tag and then put the above code.

    Hope it helps! Please feel free to ask more questions if you have any.

    Have a nice day!

    Cheers,
    Ash

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.