[CoursePress Pro] CoursePress Pro Theme not displaying course content

I have previously developed a childtheme for the CoursePress Theme which was in use on this site and was working until recently. since WP 5.0 the site has stopped displaying the course contents on either the Child Theme (sophia LMS) or the parent theme CoursePress.
As a stopgap measure I have reverted to Tweny Nineteen but that obvously means all styling on the site has been lost.

Could you have a look at the Parent Theme and let me know what is causing this issue>?
I have tried updating to the latest release of the CoursePress pluginm but that doesn't seem to fix the issue and I suspect has not updated the Theme file anyway (thus creating more incompatibilities).

  • Dimitris
    • Support Star

    Hello RethinkMarketing,

    hope you're doing well!

    I just tried to replicate this in a local site of mine and realized that with the latest update there's no CoursePress theme listed in Themes. That's clearly some kind of bug, so I've already created a task for our developers.

    As this is most probably the reason for the above error, could you please try to downgrade CoursePress and see it this remains?
    https://premium.wpmudev.org/project/coursepress-pro/

    If not, then this may be an issue in your child theme, as I wasn't able to see any broken pages in my tests when using:
    - WP 5.1.1
    - CoursePress 2.2.0 and the included v.2.0.6.1 CoursePress theme

    Looking forward to your results!
    Thank you,
    Dimitris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.