[CoursePress Pro] Courses do not show units when Membership 2 is enabled

I am using CoursePress Pro with Membership 2, and I'm having difficulty accessing the units of my courses.

When Membership 2 is enabled, a student (who has the correct membership) cannot view the units, it says - "No visible units in the course currently. Please check back later."

Please advice.

  • Dimitris
    • Support Star

    Hey there Simon,

    hope you're doing good! :slight_smile:

    I've already forwarded this to our Second Level Support team, as they had handled a similar case in the past. Me or another colleague of mine will keep you posted here as soon as possible! Please keep in mind that response time of SLS team is a bit larger than ours, as they're looking at much complicated tasks. Your patience on this is highly appreciated!

    Warm regards,
    Dimitris

  • Ari
    • Recruit

    Hey Simon

    Hope you are fine,

    This issue seems fixed now, our plugin used three custom post types: course, unit, module.
    course is parent and unit, module are child items. There are no way to set protection rule for child items, but for parent one, child items are usually set to null, so it uses parent state.

    But in your case, child items were set to false, not sure how false value was set to them, I have manually updated these value to null, now it seems working.

    for testing purpose, we made few changes in your site like: creating multiple users, delete and recreate the membership, disabling add-on.

    Have a great day!

    Regards,
    Ari

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.