[CoursePress Pro] Divi doesn't let coursepress pro course setup load

New Divi update doesn't let coursepress pro course setup page load. I rolled back divi to version 3.17.6 and it loads fine.

  • Nithin
    • Support Wizard

    Hi Eric Johnson,

    I could notice styles not loading correctly in the CoursePress editor, however other than that I was able to setup, and create new course without any issue with latest version of Divi v 3.18.7.

    Maybe I’m missing something, could you please share a screenshot on where you are seeing the issue.

    Also, if possible maybe you could enable support access to a site where you have latest version of Divi, and CoursePress so that we could have a better idea regarding this issue. You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Please let us know once you enable access, so that we could get this sorted. Have a nice weekend. :slight_smile:

    Kind Regards,

    Nithin

  • Eric Johnson
    • The Incredible Code Injector

    Hi Nithin,

    I wasn't able to replicate it on another network, it seemed to work fine. I just have to switch back to the standard editor.

    But, on the site I am having issues with, it gets stuck loading the "new divi builder" (see screenshot) and I cannot click to load the classic builder or click to load the standard editor. Apparently this is only happening with courses I've already created. I created a new course and the divi builder didn't show up.

    To edit the current courses I can go into divi theme options and turn off the "new builder" and then that allows the page to load properly and then it allows me to switch back to the standard editor which allows me to then edit the course setup. This might be a temporary fix for when I need to edit courses.

    I've granted access.

    Feel free to experiment with the fitness foundations course, that one isn't built yet.

    Thank you,

    Eric

  • Nithin
    • Support Wizard

    Hi Eric Johnson,

    Could notice that in your system, this is really an odd behaviour, and I don’t see any option to load the default editor out of the box in your system. As you have stated, it works fine for newly created courses without any issue.

    I tried to disable Divi Builder in general for all under Theme Options, still it keeps on loading. I tried to replicate the same in my system, but it works fine.

    Do you think is there any specific steps needed to replicate this issue? Is it possible to quickly disable all the plugins in your system, and see how the course loads?

    This should give a better idea whether an existing plugin is causing a conflict with the latest update of the theme, or not too. Please let us know whether you are comfortable with us running a conflict test, so that we could have a better view.

    Regards,

    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.