CoursePress Pro errors with PHP 7.1.1

hi
i keep getting errors when creating courses with php 7.1.1
i say this because with no other plugins activated i still get the error and when switching to php 7 the errors do not exist.

support access granted if required.
kind regards.
i would love to use 7.1 because it seems to be just a bit faster than 7.0