CoursePress Pro fresh install in a new directory.

OK. I have done everything you asked me to do. I have a fresh install in a subdirectory of http://www.spirit-edu.com of WPMU Dashboard, CoursePress Pro, and Marketplace.

I increased the the memory allocation in the wp-config.php to 1 gig, which is the max available, and I have only two websites on the serverthis one http://www.spirit-edu.com/learn and the one above, which means my server space is at 17% of its 60 gigs. It's a VPS linux server.

The above and Jetpack and Akismet are the only plugins installed in this install.

I put together a course, filled out the Paypal API, pricing everything that needs to be done.

1) The WPMU Dashboard doesn't show up in the backend, but shows as being installed and activated.
2) When logged out and you hover over "Courses" in the menu, there are no dropdowns (submenus) showing for "My Courses," Login, etc, like there were in the install I had done before.
3) When I do click on "Courses" I am taken to the course page, and it loads and I scroll to the bottom to click on "Details" it takes me to the full course description, but there is no button to "Enroll" or to Sign in.
4) I can go to "browse Products" in the right column (widgets area) and from there go to the cart and attempt to buy the product, but unless I previously have a user name and password, I can't login to pay for the course.

I have not a clue as to where to go from here, and although I can't give you backend access through the WPMU panel, I do have a username and password I can email you to check it all out.

The WPMU dash is installed on the http://www.spirit-edu.com site, but I kept them as separate installs.

Your assistance would be greatly appreciated, if I am to have a course starting in 2 weeks.

  • Vinod Dalvi
    • WP Unicorn

    Hi @jtstarke,

    I hope you are well today and thank you for your questions.

    1) The WPMU Dashboard doesn't show up in the backend, but shows as being installed and activated.

    This can be due to permission issue.

    Could you please simply put either of these constants in your wp-config.php file:

    define('WPMUDEV_LIMIT_TO_USER', '1');  // for one user.
    define('WPMUDEV_LIMIT_TO_USER', '1, 10'); // for multiple users (they are all user IDs).

    Place either of these just above the following line:

    /* That's all, stop editing! Happy blogging. */

    You may need to activate the plugin to trigger the new permissions. To do so, you can simply log in, deactivate then immediately reactivate the plugin.

    Find more information about it on the following page.

    https://premium.wpmudev.org/project/wpmu-dev-dashboard/#usage

    2) When logged out and you hover over "Courses" in the menu, there are no dropdowns (submenus) showing for "My Courses," Login, etc, like there were in the install I had done before.

    You will get my courses, dashboard etc. menus after logging in.

    I can see the login menu on your site http://spirit-edu.com/learn/ as displayed in the attached screenshot.

    3) When I do click on "Courses" I am taken to the course page, and it loads and I scroll to the bottom to click on "Details" it takes me to the full course description, but there is no button to "Enroll" or to Sign in.

    4) I can go to "browse Products" in the right column (widgets area) and from there go to the cart and attempt to buy the product, but unless I previously have a user name and password, I can't login to pay for the course.

    Make sure in the "Enrollment & Course Cost" section you have set anyone to enroll in the course as shown in the attached screenshot.

    Best Regards,
    Vinod Dalvi

  • Vinod Dalvi
    • WP Unicorn

    Hi @jtstarke,

    Thank you for your reply.

    There is no option in my menu for "anyone" see screenshot

    Also, you can't sign in as a new user from the login screen. There is no option

    You should enable user registration on the following pages.

    https://premium.wpmudev.org/manuals/the-buddypress-manual-2/letting-people-register/
    https://premium.wpmudev.org/blog/daily-tip-how-to-turn-registration-on-and-off-for-wordpress-multisite/

    and the WPMU Dash does show up in all my other installs, which is the only way I could give you backend permission.

    Do you mean it displays on your other websites but not on http://www.spirit-edu.com/learn ?

    Have you tried using the solution as described in my previous reply?

    Regards,
    Vinod Dalvi

  • jtstarke
    • Site Builder, Child of Zeus

    Back to the drawing board. I made your suggested change to the config file and forgot to save a copy of the original and messed it up. went to replace with a copy I had that I thought was from this install but it wasn't so now I'm working from yet again a fresh install. I would still like an explanation for the above comments, because I'm sure nothing will change by tomorrow. I don't understand why I don't have an "anyone" option.

  • Ash
    • WordPress Hacker

    Hello @jtstarke

    "Anyone can register" is not a buddypress feature, it's wordpress' default feature.

    If you are in a single wordpress site, you need to go to Dashboard > Settings > General > Membership > And check the box for Anyone Can register > Save.

    If you are in multisite, you need to go to Network Admin > Settings > Network Settings > Registration Settings > Allow new registrations > And select either "User accounts may be registered." or "Both sites and user accounts can be registered." > Save.

    This will enable registration in your site.

    Please let us know if that works for you.

    Cheers
    Ash

  • jtstarke
    • Site Builder, Child of Zeus

    Thanks ash. That was one of my many problems. Someone aught to compile all these errors into a tips for CoursePress and some of the other plugins. I seem to have made all of them lately. My final one before my install finally worked was a PayPal 10005 error, which made me crazy and really couldn't see. It turned out to be a space in front of my API username.

    Now it's just into the tweeking, but at least we can get people signing up for courses.

    Thank you!

  • Ash
    • WordPress Hacker

    Hello @jtstarke

    I hope you are well today.

    Glad to hear that you got everything working :slight_smile:

    my install finally worked was a PayPal 10005 error, which made me crazy and really couldn't see. It turned out to be a space in front of my API username.

    I believe you copied the information and pasted in there. We all do this mistake, haha. Most of the time, it takes an extra space at the end of the string. So, always it's better to type manually username, passwords, api info etc :slight_smile:

    If you have any more issues on this, feel free to add here. And if you get any new issue, please create a new thread https://premium.wpmudev.org/forums/#question :slight_smile:

    Cheers
    Ash

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.