CoursePress Pro Passcode not required to sign up

Hey, me again!

So, I set up a course with a passcode, but when you click on Signup, no passcode is required.

You will see in the screenshot that in the background, it does say a passcode is required, but in the form all you need is to create your own password.

Am I missing something here?

Thanks for any help!

-dan

  • Dan
    • Site Builder, Child of Zeus

    Hi Jack,

    Ok, that is not quite I had understood, but if that were the case it would work. You will see the attached files. First from the signup process, and the second right after the signup process, but no passcode was required.

    Is this a bug, or am I doing something wrong?

    Thanks as usual for the excellent support!

    -dan

  • Jack Kitterhing
    • Code Norris

    Hi there @Dan,

    Hope you're well today! :slight_smile:

    I've been looking into this on your sub site and have a theory, you have a cache running, if the content isn't excluded from the cache it could cause a issue, try with that disabled.

    My second theory is your units are in draft and not live, try setting a unit to live and see if it requires the passcode then (I would have done this, but I wasn't sure if you wanted the units live yet, I presumed not). :slight_smile:

    Please advise, if either of those resolve this, if not I'll take another look. :slight_smile:

    Thanks!

    Kind Regards
    Jack.

  • Dan
    • Site Builder, Child of Zeus

    Hi Jack,

    I checked into your suggestions. Unfortunately, neither solved the problem. Once registered, users have the option to "Start Learning Now", and that takes them straight to the course.

    One thing I did notice though, is that if you have a student signup independently, then take them to the course page, a passcode is required. So as far as I can tell, this bug occurs only when a person signs up completely from the course page, as it registers the student for the site and the course as well.

    Can this be fixed quickly? I was going to invite my customers to sign up tomorrow.

    -dan

  • Jack Kitterhing
    • Code Norris

    Hi there @Dan,

    Hope you're well today, thanks for your patience on this.

    On my test site, I've just signed up directly from the course page with MarketPress payments enabled for the course and it required the passcode.

    But then I removed the payments and made the course free and you are correct that it bypasses the passcode if signing up directly to the course.

    I've notified the lead developer so we can get this fixed up right away. :slight_smile:

    Kind Regards
    Jack.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.