[CoursePress Pro] Trying to save units causes timeouts

I have two sites - the live version at presentationfff.org and the test version at beta.presentationfff.org. I copied the live site to the beta site and updated CoursePress Pro from 2.0.7 to 2.2.0. The live site is fine. The beta site at 2.2.0 hangs when I click on Save Whole Units when editing the course OR if the save works OK, it hangs trying to navigate away from editing the Course. I get:
"Connection lost. Saving has been disabled until you’re reconnected. We’re backing up this post in your browser, just in case."
All other activities in the admin of the site seem to work fine.
Running WordPress 4.9.6.
Enabled support login.

  • Katya Tsihotska

    Hi Robert

    Hope you're having a wonderful day!

    I've tried to access your test site, but it looks like support access isn't enabled. I've also tried to replicate this issue on my test install with the latest version of the CoursePress Pro but wasn't able to replicate.

    Error that you're getting is a general WordPress error which happens when you lost internet connection or when WordPress is having troubles with saving posts/pages/custom post types. Usually, tweaking AutoSave Interval helps to solve this issue. In order to increase autosave interval, try to add the following code to your wp-config.php file:

    define( 'AUTOSAVE_INTERVAL', 160 );

    If this doesn't help, in order to diagnose your issue, I'd request you to perform the two tests mentioned in the following:
    1. Plugin conflict test. The simplest way to perform a plugin conflict test:
    * Login to your site via FTP
    * Navigate to wp-content
    * Rename the plugins folder to _plugins
    * Create a new empty plugins folder
    * Move the plugin folder (coursepress) you want to test from _plugins to plugins
    * Check if the issue still persists, if no, proceed to the next step
    * Then, one at a time, move other plugin folders over from _plugins to plugins until the symptom returns

    NOTE: While you are doing this, do not visit WP Admin > Plugins on your site. This will ensure that your plugins remain active when you copy them back over.

    Let us know about results.

    2. Enable wp debug. To enable WP_DEBUG, change the following line in your wp-config.php file:
    define('WP_DEBUG', false);
    To this:

    // Enable WP_DEBUG mode
    define( 'WP_DEBUG', true );
    // Enable Debug logging to the /wp-content/debug.log file
    define( 'WP_DEBUG_LOG', true );
    // Disable display of errors and warnings
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );

    Please make sure to add the above code just before the line /* That's all, stop editing! Happy blogging. */

    After this, try to replicate issue again. Then go to /wp-content folder and check if debug.log file is there. If it's there. download it, save as debug.txt and attach to your next reply.

    If nothing from the above give you any results, you can send us your details through our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question using this template:

    Subject: "Attn: Katya Tsihotska"
    -WordPress admin username
    -WordPress admin password
    -login URL

    -FTP credentials (host/username/password)
    or
    - cPanel credentials (login URL/username/password)

    -link back to this thread for reference
    -any other relevant URLs

    Please use this subject line to ensure that it gets assigned to me :slight_smile: And please, DO NOT post any credentials here, as it's a public forum.

    Kind regards,
    Katya

  • Robert

    Thanks for the tips. It seems to only happen when I have WatuPro active at the same time. Nothing in the debug log. And it only happens when I save CoursePress posts. The save works and then when I try to navigate out of the Course to show my list of courses, the server goes to 50% and I get gateway timeouts. Takes about 10 minutes to recover. I know I need to pursue with WatuPro but if there's any other ideas you might have, I'd appreciate it! I granted access and sent login information.

  • Katya Tsihotska

    Hi Robert

    Hope you're well!

    I've tried to log in to your site with credentials you've sent, but got the following error:
    ERROR: Invalid username.

    Could you please double check credentials? You can send new credentials through our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question using this template:

    Subject: "Attn: Katya Tsihotska"
    -WordPress admin username
    -WordPress admin password
    -link back to this thread for reference

    Let me know once you'll send it.

    It's also would be helpful if you'll contact the Watu Pro support team, in case if the cause of the issue is on their side.

    Kind regards,
    Katya

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.