CoursePress Pro "units" keep going from live to draft

CoursePress Pro "units" keep going from live to draft on their own.. like they have a ghost.
I will click them live.. and then they will immediately revert back to "draft" right before my eyes..

  • Nithin
    • Support Wizard

    Hi Craig,

    Hope you are doing good today. :slight_smile:

    It seems like the support access isn't enabled anymore, I suppose it got expired. Could you please enable support access, so that we could give a closer look. You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please let us know once you enable access, so that we could get this sorted. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Nithin
    • Support Wizard

    Hey Craig,

    Hope you are doing good today. :slight_smile:

    I checked your website, ie automated.xxxxxx and I don't see CoursePress plugin installed in it? Could you please advise what I'm missing here?

    I was able to notice that CoursePress is installed in faith.xxxxxxx website, but the support access isn't enable for that site. Am I checking the wrong website? Please advise, and we'll make sure to get back to you asap.

    Kind Regards,
    Nithin

  • Kasia Swiderska
    • Support nomad

    Hello Craig,

    Sorry for the delay on our end. I checked your site, but there was no errors in browser console that would quickly explain what is happening there.
    I did also checked your system memory limits and max_execution_time is bit low - I would like to first check if increasing it will help - https://premium.wpmudev.org/blog/increase-memory-limit/
    Your current limits can be found in WPMU DEV -> Support -> System Info.

    If that wont help can you enable debug log in your WordPress and then try again saving new unit. To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:
    define('WP_DEBUG', true);
    In order to enable the error logging to a file on the server you need to add yet one more similar line:

    define( 'WP_DEBUG_LOG', true );

    In this case the errors will be saved to a debug.log log file inside the /wp-content/directory.

    Depending on whether you want your errors to be only logged or also displayed on the screen you should also have this line there, immediately after the line mentioned above:

    define( 'WP_DEBUG_DISPLAY', false );

    The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

    I would need then to see content of the debug.log file - so please upload it to service like a Dropbox and paste link here.

    kind regards
    Kasia

  • Craig
    • Site Builder, Child of Zeus

    Well, when it comes to memory limits... Cloudhosted just added hard limits... to their shared server accounts...
    https://support.cloudhosted.com/articles/employees/php-settings-that-cannot-be-changed
    safe mode = Off (cannot adjust)

    memory_limit = 256M (MAXIMUM)

    max_execution_time = 30 (MAXIMUM in seconds)

    max_input_time = 60 (MAXIMUM in seconds)

    post_max_size = 64M (MAXIMUM)

    upload_max_filesize = 64M (MAXIMUM)

    enable_dl = Off (cannot adjust)

    debug.log attached...

    Thank you so much!

  • Nithin
    • Support Wizard

    Hi Craig,

    Hope you are doing good today. :slight_smile:

    Unfortunately the debug.log file didn't get attached in your above reply, the file has to be in txt file format, as that's the only format you can attach here. If not, you'll have to make use of cloud services like Dropbox, or Google Drive to share the link to your debug.log file.

    I tried to replicate this issue in my system, but it seems to work fine. However, I was able to find a workaround, that is you'll have to save the courses, and the units. And then navigate back to CoursePress Pro > Courses, and then editing the units for your courses, seem to work fine. That is, I wasn't able to notice the units changing from draft to live, or vise versa once I did that.

    Please do share the debug.log, so that we could have a better idea about what could be causing this, whether it's related to memory limit, or something else. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Ivan
    • Developer

    Hello Craig !

    It seems you use Multisite and don't have an important table for it into your database.

    Could you please send credentials by using our secure contact form for checking it: https://premium.wpmudev.org/contact/#i-have-a-different-question

    - To Mark to my attention, the subject line should contain only: ATTN: Ivan Svyrskyi
    -WordPress admin username
    -WordPress admin password
    -login url
    -CPanel credentials (host/username/password)
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Best regards,
    Ivan.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.