coursepress Pro units saving problems

Dear sirs, i have read quite a few posts about problems in saving courses units that were supposed to be solved moths ago, now I have to start building my course that I am going to sell so i really need to know if and when you are going to release a stable update that make it possible to create and run online courses, or I will have to find another solution, thank you very much, Marco

  • Rupok
    • Support Ninja

    Hi Marco,

    I'm so sorry if you are having any inconvenience with CoursePro. I'm running CoursePress Pro latest stable version on my test site and I can save units without any issue. So I think, this will work absolutely fine on your site too. And the reports you mentioned, those are not generic, and only a very few people faced this. Well, some plugins may behave weird sometimes depending on server configuration, but as I could not regenerate this on my test site, I don't think this is a generic bug, rather those issues are isolated on their sites only. I really believe, you won't face this units not saving issue on your server.

    I can see that you are still using CoursePress version 1.3.4.3 which is an older version. If you are planning to upgrade, I'll suggest you to create a clone of your main site (which we call a staging site), then update CoursePress there and check how it goes. If everything is alright, then you can update on your live site.

    If you find any issue after updating to latest version of CoursePress Pro in your staging site, please let us know. We will be glad to work on that and will try to fix your issues as soon as possible. And when all issues are resolved (if there is any issue), you can deploy those fixed on your live site too after updating.

    CoursePress Pro is a very powerful and awesome plugin. I think you should continue using is if you are willing to create a beautiful and powerful online education site.

    Please let us know if you have any confusion. We will be glad to help.

    Have a nice day. Cheers!
    Rupok

  • Marco
    • WPMU DEV Initiate

    Hi Rupok, i tried to install the latest version, but when i checked on the plugin list it says version 2.0.1 and this confuses me. I am on wp 4.6.1 and granted you access to check if I did something wrong, thank you, Marco

  • Kasia Swiderska
    • Support nomad

    Hello Marco,

    Yes, you have CoursePress Pro 2.0.1 installed on site where you enabled access - that is different site from one related to this thread - we can see in thread site url and plugin version that is used on site and for that site old version of CoursePress is used.
    So on site where you opened access you have the latest version.
    CoursePress Pro 2 was rewritten and some parts are working now in different way, better way - like saving units. You should not have problems with that anymore.

    Please let us know about any issues you are having there (in CoursePress 2.0.1) so we could investigate those.

    kind regards,
    Kasia

  • Nithin
    • Support Wizard

    Hi Marco,

    Hope you are doing good today. :slight_smile:

    I tested in my system with the latest version of CoursePress Pro, and I was able to save the units without any issue. This seems to be an issue specific to your system, just to be sure did you perform plugin conflict test as illustrated in getting support manual (flowchart), and rule out whether any plugin is causing this issue.
    http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    If you have already performed that, and since the support access isn't enabled I wasn't able to check your system, to have a better understanding about the issue, please enable support access, so that we could help get this resolved asap.

    You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please let us know once you enable access, so that we could get this sorted. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.