[CoursePress Pro] Youtube Video Not Responsive on CoursePress Pro

Hello, youtube video is not responsive on my website. Can you please help me make it work as all method I have tried proved abortive. I need it urgently. Thanks

  • Adam Czajczyk

    Hello Raphael

    I hope you're fine today!

    I understand that you're referring to the YouTube videos added to the course using the CoursePress "video" module, is that right?

    Have you set the player width and/or height in video module settings? If yes, try removing them and re-save the units. If that doesn't help, I think it's most likely somehow related to the theme or other plugins and I'd like to take a closer look.

    In such case, could you please:

    - enable support access to the site by going to the "WPMU DEV -> Support" page in your site's back-end and clicking on "Grant support access" button there?
    - let me know where exactly can I see video(s) in question on your site, both on front- and in back-end?

    Best regards,
    Adam

  • Predrag Dubajic

    Hi Raphael,

    There's a lot of capabilities assigned to the instructor and it would be best to create your role based on those, and remove any that you don't want them to have.
    To do this create new user on your site, it can have Subscriber role as well.
    Go to your courses and assign that user as an instructor for any of your courses and save the settings.
    After that go to All Users panel, edit the profile of your newly created account and scroll down where you will see a list of all the capabilities that they have assigned as an instructor and you can now use that information to create your own instructor role.

    Hope this helps :slight_smile:

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.