Coursepress Theme and bbPress Integration

Questions 1:
I have setup my Coursepress site and have enabled it's theme. I have installed bbPress and BuddyPress.

Have setup a forum test page with test forums. the pages does not reflect any replies being posted. it shows that there are 3 replies and 2 voices, but it does not show the acutal replies.

I changed the them to Fifteen to test if there was theme issues. and on Fifteen them, the post do show and replies how threaded. but when I go back to Coursepress theme, they don't show. Help!

Questions 2:
I can seem to find any documentation that i dummy (newbie) proof to use Protected Content to setup my LMS sight with membership levels.

Example:
Level 1= (access to forum only, ie. bbPress)
Level 2=(access to forum and Courses 1, 2)
Level 3 = (access to forum and Courses 3, 4)

Any help would be appreciate. Or, if you could direct me to right place to get someone to setup my sight, saving me lots of learning curve hours!!

simple .jpg attached.

Alex

  • Tyler Postle

    Hey Alex,

    Hope you're doing well today!

    Have setup a forum test page with test forums. the pages does not reflect any replies being posted. it shows that there are 3 replies and 2 voices, but it does not show the acutal replies.

    i've replicated this on my install as well, I'm flagging the developer so this can get fixed up :slight_smile: thanks for bringing it up!

    I can seem to find any documentation that i dummy (newbie) proof to use Protected Content to setup my LMS sight with membership levels.

    Example:
    Level 1= (access to forum only, ie. bbPress)
    Level 2=(access to forum and Courses 1, 2)
    Level 3 = (access to forum and Courses 3, 4)

    There is a bbpress add-on you use via:

    Protect Content > Add-ons > bbpress integration.

    Then you can manage that protection via: Protect Content > Protected Content > bbpress.

    As for the courses, you will want to use URL groups :slight_smile:

    So for example, this could be a url group:

    /courses/testing-course/.+

    That would protect the Testing Course so no one would be able to access it unless they had the correct Protected Content Membership :slight_smile:

    Any help would be appreciate. Or, if you could direct me to right place to get someone to setup my sight, saving me lots of learning curve hours!!

    If you're wanting someone to get everything completely set up for you then you may want to look at posting on our jobs board: https://premium.wpmudev.org/wordpress-development/

    Then an experienced member of the community can help you out :slight_smile:

    If you need help here and there while you are setting it up then just let us know. We're more than happy to assist.

    Look forward to hearing back!

    All the best,
    Tyler

  • Alex

    I have setup Protected content by using the tutorial and have followed all instructions best as possible.

    I have setup up two membership levels and have given access to pages, forums, etc.

    What I am having trouble with is what visitors can see on the page. For instance, when an non-members see the home page and clicks on courses, it show No Courses Found. ( have three test courses live on the only show when i am registered as admin)

    When they click on Forum, it only shows the standard message (oh bother! etc)
    I have set Forums as a membership lever. Shouldn't it read, "to get access to this page, please subscribe"? (that is the default message enabled)

    Confused!

    Please help with this and the above questions. I purchase the yearly membership after reviewing your plugins. They are conveyed as easy to use via your videos and information. But now that I have access to them, it is quite evident that the plugins take quite a bit of learning curve and are not as easy as they are displayed on the sales page. After noticing lots of the support questions, there seems to be a need to update plugins, or changing of or adding or updating scripts, etc. It also seems like the normal person has to understand how to do some scripting and editing individual plugins to make them work on their hosting sites.

    Frustrated!
    alex

  • Alex

    I finally had to deactivate Content Protection because it would not show any of the visitor pages, I could not see the courses, or the home pages, or anything.

    i was still using Courpress Theme and Coursepress pro.

    Now, I just have those two main plugins running, I have two paid courses.

    I have invited 3 student to take the course for free. but they cant log in because it requires them to pay. i have added them on wordpress so they have a subscription and i sent them invites via Coursepress add student.

    but how can i get them to join for fee in a paid course?

  • Michael Bissett

    Hey @Alex, Michael here from the live chat earlier today. :slight_smile:

    Just as a quick thought, I'd like to ask, do you have the "Custom Post Type Protection - Post by Post" add-on enabled inside your site presently? The behavior you're running into sounds similar to another thread I worked on recently, and enabling that add-on helped that member out.

    Should it not resolve the issue though, the Support Access you've granted appears to have expired, could you please re-enable it, so that I can have a closer look at your settings here, and advise further? :slight_smile:

    Please advise,
    Michael

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.