CoursePressPro not saving units or let me edit content

Hi there, I am trying to use CoursePress and when I try to create a unit: fill in the title and clic save, it just disappears. And the edit unit part is always in "Loading units elements". How can I solve this?

I would like to know also, how to change the template for the course? I dont want to have the sidebar and the menu within the course, how can I do that?

  • Adam Czajczyk
    • Support Gorilla

    Hello Ines,

    I hope you're well today and thank you for your question!

    I reviewed your site and checked its settings. It seems that the "CKEditor for WordPress" is causing that issue. I was able to replicate this on my own site and it sounds like incompatibility.

    That said, I'm reporting this to CoursePress developer as a bug. Hopefully he'll be able to track down the source of the problem and fix it, though I'm not able to give you any ETA on this.
    A temporary workaround here that would let you create courses would be to disable the "CKEditor for WordPress" plugin while adding/editing units.

    Please keep an eye on this thread for further information and/or code patches and also make sure that you keep CoursePress Pro up to date.

    Best regards,
    Adam

  • Ines
    • Design Lord, Child of Thor

    Hi Adam,
    I uninstalled and it worked, thanks for that, not ideal, but a temporary solution, thanks!

    I would like to know also, how to change the template for the course? I don't want to have the sidebar and the menu within the course, how can I do that?

  • Predrag Dubajic
    • Support

    Hi Ines,

    There's no need to uninstall CKEditor, you can temporarily disable it while editing courses.

    I would like to know also, how to change the template for the course? I don't want to have the sidebar and the menu within the course, how can I do that?

    This mostly depends of the theme you are using on your site, if you could grant us support access to your site to check your theme options we can see what would be best solution for your case :slight_smile:

    To enable support access you can follow this guide here:
    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Best regards,
    Predrag

  • Ines
    • Design Lord, Child of Thor

    Hi, When I finally manage to set up a unit I have this error
    Warning: array_key_exists(): The first argument should be either a string or an integer in /home/inesrn3/public_html/wp-content/plugins/coursepress/includes/classes/class.course.php on line 374
    +no content +all the comments from the blog. How can I sovle that?
    Best

  • Predrag Dubajic
    • Support

    Hi Ines,

    I forgot about the course layout you asked for about above, this CSS should do the trick, just add it to Appearance > Custom CSS field:

    body[class*="unit-courses"] .widget-area,
    .units .widget-area,
    .single-course .widget-area {
    	display: none;
    }
    
    body[class*="unit-courses"] .site-content,
    .units .site-content,
    .single-course .site-content {
    	width: 100%;
    }

    What about all the comments and not showing the content?

    I'm not sure what this is for, can you please elaborate your question a bit?

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.