Courses "instructor" link presently says not found.

A plugin conflict test was done and the link for the course instructor is still missing. I have the same issue with the link to the cart. I am using MP2.

  • James Morris

    Hello Dr. Ashley M. Berge,

    I hope you are well today. I'll be following up with you regarding your chat.

    The problem you're running into is whitespaces in the URL strings (blank spaces). WordPress doesn't handle spaces in the URL strings well and with throw a 404 error. This isn't specific to CoursePress, but rather the WordPress core. Since author/instructor permalinks are generated by the username, and your username has spaces in it, this is why you are having this issue. However, CoursePress has a nice feature built in... You can disable the Show Instructor Username in URL setting in WP Admin -> CoursePress -> Settings.

    I've deselected this option for you on your site and verified that the Instructor URL is working correctly.

    If having the Instructor name in the permalink is absolutely essential to you (for example, for SEO purposes), you may want to look into the https://wordpress.org/plugins/edit-author-slug/ plugin. This will allow you to fully customize the permalinks for your author/instructor slugs.

    Can you please check and verify that all is working correctly now?

    Best regards,

    James Morris

  • Dr. Ashley M. Berge

    Hi James,

    Thanks for looking into it -- I've changed the name to remove the space -- when you click on it, it goes to the 'image' of the user which is distorted (like, the picture and a 1/4 showing) and no link to profile etc is displayed (1); the intent is for users to be able to 'read' a little and interact with the instructor but nothing is showing... Also, there is no link to the cart -- so if a user clicks on the course they are not taken through to the Store -- that's a little confusing, I'm after it to be integrated as I believed, so I'm not too sure what's happening here (2); and the header background is all white -- as is the text -- is there a way to alter this to a pictured background, for example, to ensure people can see the titles more clearly?

    Thank you again for getting in touch as I understand it is a bit of a tedious issue!

  • Ash

    Hello Dr. Ashley M. Berge

    When I clicked on the instructor name fro course page, it took me to the archive page, not to any distorted image page.

    There is a floating cart on the page, user can use that to visit the cart page.

    About the header background, please try the following css:

    .single-course .page-cover{
    background: url(PATH_TO_IMAGE) !important;
    }

    You can use this css in a plugin called Simple Custom CSS: https://wordpress.org/plugins/simple-custom-css/ Or you can use a child theme: https://premium.wpmudev.org/blog/how-to-create-wordpress-child-theme/

    Hope it helps! Please feel free to ask more questions if you have any. Also, let me know if I am missing anything.

    Have a nice day!

    Cheers,
    Ash

  • Dr. Ashley M. Berge

    Thank you Ash!

    I was able to update the text of the Course so the background wasn't a must -- but thank you!
    The image, too, was fixed.
    However, an overriding issue is that the "instructor" link is not working -- in the course view list (courses) and where it says "instructor" -- click on "instructor name" and what appears is the 'image' of the instructor, and then the course below -- nothing else -- I'm after a 'link to profile' from the initial click -- so, when someone clicks on the 'instructor' link/name to begin, they would automatically be redirected to their profile?
    Also, when a user clicks on the "course" at this step, rather than taking them to a replicated page -- they need to be directed to the "cart" where there is information AND it prompts them knowing they're in the 'cart' and they need to make a transaction etc...
    Also, when you look further on the 'profile' page and click 'courses' it takes you to 'available courses' and the layout is rather scary -- this needs to be tweaked -- so a few things with CoursePressPro that need tweaking and if you're able to help, thank you kindly!

  • James Morris

    Hello Dr. Ashley M. Berge,

    As discussed in our emails, I've applied all the changes pertaining to this issue from the staging site over to your production site. All is working correctly now. Here's the summary from our discussion related to this issue:

    - CoursePressPro instructor link is the same i.e. you click on instructor name and it take you to the 'picture' (not the person)

    This is because CoursePress does not link to BuddyPress profiles. The instructor profile always points to the Instructor Page in CoursePress.

    However, in WP Admin -> CoursePress -> Settings, changing Instructor Profile Slug to members, which is the slug for BuddyPress Member Pages, this allows you to link directly to the Instructor BuddyPress profile.

    NOTE: The option Show Instructor Username in URL must be set to yes for this to work properly.

    One problem with your site is that Dr. B has the Username "Dr. B" With a space. This doesn't work well. Changing this to match the BuddyPress string of "dr-b" resolves this issue. So, this user's WordPress username is now "dr-b", but their Display Name is still "Dr. B".

    Let us know if you have any further questions. We'll be happy to help!

    Best regards,

    James Morris