[CoursePress] upgrade issue from 1.3.4.3 to 2.2.2

I was using coursepress 1.3.4.3 version. Now I updated it to 2.2.2. Also after that, I tried upgrading data but it didn't work.
Now I'm not able to view my coursepress menu in the admin panel.

It seems the upgrade gets stuck.

  • Adam Czajczyk
    • Support Gorilla

    Hello Ajay M Aravind

    I hope you're well today and thank you for your question!

    A switch from 1.3.4.3 version to 2.2.2 release was a very huge "jump". The code of version 2 was rewritten from scratch in big parts and significantly re-factor in some other areas. There were numerous updates meanwhile too.

    In case of similar updates, it's strongly recommended to do it gradually - it applies not only to CoursePress and our plugins but to pretty much every plugins/theme that's update from very old version to the newest one. There's too many changes "on the way" and to many possible unexpected issues that might come out of it so what's happening now might be quite difficult to diagnose, I'm afraid.

    That being said, the most recommended course of action in this case would be - if possible - to restore the site from some backup to the most recent state from right before the update and then go through updates gradually:

    1)

    - download version 2 from here
    https://premium.wpmudev.org/download/341096564_coursepress-pro-2.0.0.zip

    - manually update it on the site

    2) repeat the same with 2.1 release:

    https://premium.wpmudev.org/download/414228206_coursepress-pro-2.1.zip

    3) and with 2.2: https://premium.wpmudev.org/download/2132596482_coursepress-pro-2.2.0.zip

    and then just update automatically to the most recent one.

    However, if it's not possible (e.g. you don't have a backup that could be used for this) please take a full backup of the site at current state and let me know once that's done (that's just security precaution, just in case) and I'll include our developers in the case so they could see how this could be fixed.

    Best regards,
    Adam

  • Ajay M Aravind
    • The Bug Hunter

    Hello Adam Czajczyk

    I just tried updating my Coursepress manually from 1.3.4.3 to Cousrepress 2.0. Next from 2.0 to 2.1. Till Coursepress 2.1 i dint't experience any issue. But after updating to 2.2.0 in my unit page (Admin backend) module section is not getting displayed. Its showing "Loading modules...". Same error in coursepress 2.2.2 too.

    In console there is a jquery error showing

    coursepress-unitsbuilder.js?ver=2.2.2:1459 Uncaught TypeError: this.$ is not a function
    at success (coursepress-unitsbuilder.js?ver=2.2.2:1459)
    at Object.t.success (load-scripts.php?c=0&load[]=hoverIntent,common,admin-bar,heartbeat,autosave,suggest,wp-ajax-response,jquery-color,wp-lists,jquery-ui-core,jquery-ui-widget,j&load[]=query-ui-mouse,jquery-ui-sortable,postbox,jquery-ui-position,jquery-ui-menu,wp-a11y,jquery-ui-autocomplete,tags-suggest,tags-box&load[]=,underscore,word-count,post,svg-painter,wp-auth-check,shortcode,backbone,wp-util,wp-backbone,media-models,wp-plupload,mediaeleme&load[]=nt,wp-mediaelement,media-views,media-editor,media-audiovideo,mce-view,imgareaselect,image-edit,jquery-ui-slider&ver=4.8.9:345)
    at i (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,plupload&ver=4.8.9:2)
    at Object.fireWith [as resolveWith] (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,plupload&ver=4.8.9:2)
    at y (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,plupload&ver=4.8.9:4)
    at XMLHttpRequest.c (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,plupload&ver=4.8.9:4)

    I'm doing this update in my another demo site. Please help me out.

  • Juan
    • Flash Drive

    Hi Ajay M Aravind,

    thanks for your reply.

    I tried to activate CoursePress Pro in your live site and I couldn't due to an issue.

    Could you please provide me access to your demo site using the following form? I will look deeper into this issue.

    Subject: "Attn: [JUAN GARCIA]"

    - WordPress admin (login URL/username/password)
    ?- (S)FTP credentials for file access (host/username/password/path of the website in question)
    - server panel/cPanel/Plesk/phpMyAdmin credentials for database access (login URL/username/password)
    - link back to this thread for reference (e.g. https://premium.wpmudev.org/forums/topic/example-topic)
    - any other relevant urls

    Keep in mind the subject line as ensures that it gets assigned to me.

    Please let me know if you have any questions.

    Thanks,
    Juan

  • Adam Czajczyk
    • Support Gorilla

    Hello Ajay M Aravind

    I hope you're well today!

    I'd like to ask if you still need assistance with the case. It's true that the CoursePress plugin is now a legacy plugin and is no longer developed but we're here to help and we will assist you with the issues.

    The error that you posted in your previous post above looks like something that's more related to theme/plugin conflicts rather than the update itself so if you're able to setup a staging environment to test, I think that could be the one with 2.2 release of CoursePress already and we'll investigate the case.

    Please note though:

    - it would be great if you could also simply upload those previous CP install packages that you downloaded to the staging site - not install, just upload both .zip files e.g. to the root folder of the install (just in case)

    - I didn't find any message from you so if you are about to send it, please send it as follows:

    Note: Don't leave your login details in this ticket.
    Instead, you can send me your details using our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question and the template below:

    Subject: "Attn: Adam Czajczyk"
    - Site login URL
    - WordPress admin username
    - WordPress admin password
    - FTP credentials (host/username/password)
    - cPanel credentials (host/username/password)
    - Folder path to site in question
    - Link back to this thread for reference
    - Any other relevant urls/info

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.