cPanel & mapping after migrating to WPMU

I’m in the last stages of migrating my three stand alone WP sites to subdomain blogs in a new WPMU network set up for this purpose. For background the new WPMU site and the old sites were all on the same host with no change in IP.

I didn’t activate the WPMUDev mapping plug-in yet because I had a ticket in with my excellent hosting service for fear I’d break something they were already working to configure from their end.

But my old domain names are still resolving to the old blogs, not the new WPMU sub domains.

My hosting service says I need to deactivate the cPanel accounts on my old domains then activate the WPMUdev mapping plug-in.

In effect I go from 4 cPanel accounts, one new and three old, to just the one for the new domain which where WPMU resides.

Is this how cPanel works in a WPMU environment? I wasn’t aware the existence of a cPanel account itself affected how the URL’s resolved.

After that, I should be able to configure and activate the mapping plug-in and my old domain names will transparently display their respective sub domain blog?

Is all this correct?

Thanks!

  • Temporal Sales
    • Site Builder, Child of Zeus

    When I go to add a mapped domain in the sub-site, I’m getting the “blank” refresh problem, as described in the FAQ portion of the plug-in instructions.

    Here’s what I’ve done so far:

    (1) As directed by my hosting service, I’ve deleted the redundant cPanel accounts.

    (2) I moved the sunrise.php file from the /wp-content/plugins folder to /wp-content

    (3) I added the define(‘SUNRISE’,’on’:wink:; text to wp-config.php right under the define(‘WP_DEBUG’, false); line.

    (4) I activated the mapping plug-in.

    (5) In the mapping plug-in’s settings, I added my server’s IP. I however don’t see the supporter’s pull-down, but I’m not using the Pro Site plug-in either.

    (6) I left the administration and log-in pulldowns as “domain entered by user”

    (7) In the sub-site, I entered the domain name to be mapped. When I click the “use” button, the screen refreshes, the domain field is blank, and there’s no indication the data was accepted. In the network admin, when I list the sites, there’s no mapping displayed in the mapping column.

    (8) Per the FAQ, I tried moving the define(‘SUNRISE’,’on’:wink:; line incrementally higher in the wp-config.php file, but without result.

    The only thing odd I see in the sub-site mapping configuration section, right above where I’d key in the domain to be mapped, the following message is displayed:

    “If you want to redirect a domain you will need to add a DNS “A” record pointing at the IP address of this server: IP not set by admin yet.”

    I don’t know if the “IP not set by admin yet” is significant or not.

    Thanks!

  • Timothy
    • Chief Pigeon

    Hey there, Brian asked that I take look into this one with you :slight_smile:

    Is this how cPanel works in a WPMU environment? I wasn’t aware the existence of a cPanel account itself affected how the URL’s resolved.

    Well kinda….

    When they have their own cPanel account you can edit their DNS to use the Dedicated IP address of your WordPress site.

    That way you can maintain separate cPanel accounts still.

    If you do not have a dedicated IP then the only other option is add those domain names to cPanel with WordPress. Then you can select the DocumentRoot.

    (7) In the sub-site, I entered the domain name to be mapped. When I click the “use” button, the screen refreshes, the domain field is blank, and there’s no indication the data was accepted. In the network admin, when I list the sites, there’s no mapping displayed in the mapping column.

    When this happens usually it’s either the define in the wrong place or the sunrise.php file in the wrong place.

    The only thing odd I see in the sub-site mapping configuration section, right above where I’d key in the domain to be mapped, the following message is displayed:

    “If you want to redirect a domain you will need to add a DNS “A” record pointing at the IP address of this server: IP not set by admin yet.”

    I don’t know if the “IP not set by admin yet” is significant or not.

    You set the IP in:

    Admin –> Network Admin –> Settings –> Domain Mapping

    I’ve seen this a couple of times though where the IP was set, can you deactivate the plugin and then network activate it again.

    If that doesn’t work then I might need to take a peak at your setup and the DB to see what’s happening or isn’t happening.

    Before that though you would need to test for plugin and theme conflicts. This is done by deactivating all plugins and using the default Twenty Eleven theme. Then test if it works, if it does then you would reactivate each one, one at a time until the issue comes up again. That would let us know where the conflict lays.

    Let me know how you go and if there are no conflicts then I can take a closer look for you.

    Take care.

  • Temporal Sales
    • Site Builder, Child of Zeus

    Before that though you would need to test for plugin and theme conflicts. This is done by deactivating all plugins and using the default Twenty Eleven theme.

    This is a brand-new setup, so the only active plug-ins is the WPMU Dev and the mapping plug-in. I have no themes installed other than the default 2011 theme.

    Nonetheless, I even tried deactivating the WPMU Dev plug-in, but the mapping problem persists.

    You set the IP in:

    Admin –> Network Admin –> Settings –> Domain Mapping

    Yes, and re-checked.

    can you deactivate the plugin and then network activate it again.

    Tried that several times without result.

    When this happens usually it’s either the define in the wrong place or the sunrise.php file in the wrong place.

    I’ve rechecked both and as far as I can tell both the define line and the sunrise.php file are where they should be.

    If that doesn’t work then I might need to take a peak at your setup and the DB to see what’s happening or isn’t happening.

    I’ve opened a ticket with my hosting service to see if they can spot anything from their end.

    Nonetheless, if you want to take a “peak” at my setup, let me know how to send you the access info.

    Thanks

    Dan

  • Temporal Sales
    • Site Builder, Child of Zeus

    Update:

    The support folks at my hosting service believe they’ve spotted the problem on the server side, not with the mapping plug-in.

    Here’s what they say:

    “You do not need to have separate cpanel accounts for the domains to set up wp

    multi-site, but the domains will still need to be added for DNS purposes,

    either as parked domains or as addon domains. I recommend addon domains, as

    those are allowed to have their own content.”

    They go on to give instructions how to create the add-on domains via cPanel.

    Once I hear back from them concerning a follow-up question, I’ll give it a try and report back here.

    Thanks!

  • Timothy
    • Chief Pigeon

    Ya, using addon and parking works because you can define the DocumentRoot (path). A dedicated IP is required when doing it through the A Record i.e. when it’s not on the same server where the DocumentRoot wouldn’t be applicable.

    Let me know how you get on with them :slight_smile:

    Take care.

  • Fullworks
    • The Bug Hunter

    Yes, parking the domains onto the multi-site c-panel is the correct approach in your situation where you effectively were in control of the 4 domains

    You will not have to modify the A records (because parking them will do that for you).

    So then just add the domain names to the mapping screen and it should all come together.

  • Temporal Sales
    • Site Builder, Child of Zeus

    My hosting service has now cleaned up my cPanel settings, made some changes in the DNS, and created the add-on domains I need to map my three blogs with the mapping plug-in.

    However, after all that, the domain mapping page on the sub-site won’t accept the input. As in the FAQ, all I get is a blank box after the form refreshes.

    My hosting service has first-rate tech support and they’re now making a final check from their end to see if there’s anything else they can spot.

    I’ll report back in a few hours.

    Thanks!

  • Temporal Sales
    • Site Builder, Child of Zeus

    My hosting service says they’ve done about all they can from their end and we’ve confirmed that the domains and sub-domains are resolving to the shared directory. (See their message appended below.)

    So, as I understand it, it’s probably an issue with my WPMU installation or the mapping plug-in?

    Thanks!

    _______________

    To confirm that the server was sending all of the requests for those domains

    and subdomains I created a test file (test.html) in their shared directory.

    http://trendawareness.temporalsales.net/test.html

    http://trendawareness.com/test.html

    http://airlinestocks.temporalsales.net/test.html

    http://airlinestocks.com/test.html

    http://frugaltrends.temporalsales.net/test.html

    http://frugaltrends.net/test.html

    all of those pages are loading the same file, so there’s nothing wrong

    with the DNS or the apache configuration on your server.

  • Timothy
    • Chief Pigeon

    Hey there.

    So are you sorted now then?

    I checked a couple of domains and see for example:

    trendawareness.com

    Goes to:

    http://temporalsales.net/wp-signup.php?new=trendawareness.com

    Which is correct if you haven’t yet added them as a mapped domain.

    So you create the sub site then go to:

    Admin –> Tools –> Domain Mapping

    And add the domain, it will then resolve to that site.

    Is that the final step you needed?

    Take care.

  • Temporal Sales
    • Site Builder, Child of Zeus

    So are you sorted now then?

    No, something just broke in the last hour or so and I can’t even access the admin panels for the sub-blogs nor can I even view the blogs using their full pathname. I’ve been off the computer for several hours, so I’m checking with my hosting service to see if they changed something recently.

    Which is correct if you haven’t yet added them as a mapped domain.

    That’s helpful in that it indicates that we’re probably looking at mapping problem, not a DNS problem (that is before my site broke in the last hour.)

    So you create the sub site then go to:

    Admin –> Tools –> Domain Mapping

    I’ve tried that at least a dozen times, without result. When I go to enter the domain I want to map, for example “trendawareness.com” it doesn’t take the data and I get the blank refresh.

    I also have the “no IP address assigned” message just above where I’d enter the domain to be mapped.

    Per earlier suggestions, I’d be happy to send you my site’s log-in information so you can take a look at it. Let me know if that’s what you want.

    Hopefully my hosting service will have the latest glitch corrected shortly so I can get back into the sub-blogs.

    Thanks!

  • Temporal Sales
    • Site Builder, Child of Zeus

    Update:

    Still working on it from the hosting side.

    One thing wrong was that I made the erroneous assumption that my VPS was a unique IP.

    But when I switched to the unique IP formerly used by my SSL certificate prior to the WPMU migration, it broke my site and I couldn’t even get in with FTP.

    Switching back to the shared IP restored my access, but obviously the WPMUDev mapping plug-in won’t work with the current IP.

    Thanks

  • Timothy
    • Chief Pigeon

    I’ve tried that at least a dozen times, without result. When I go to enter the domain I want to map, for example “trendawareness.com” it doesn’t take the data and I get the blank refresh.

    When you say a blank refresh what do you mean the site loads as normal but the field is blank?

    Or you get a totally blank page?

    If it’s the latter then can you please check your error logs and let me know what is output there. Your host can tell you where these are if you don’t know, it can vary from host to host.

    I also have the “no IP address assigned” message just above where I’d enter the domain to be mapped.

    This doesn’t affect the mapping, it only affects the IP being shown. I’ve confirmed today this is a bug, temporary fix here:

    https://premium.wpmudev.org/forums/topic/ip-address-does-not-show-in-site#post-309523

    Providing the IP address has the DocumentRoot of your WordPress install then it should work.

    Let me know what happens with your host once they’ve done what they’re doing and if you still need help and for me to look at your install I can.

    Take care.

  • Temporal Sales
    • Site Builder, Child of Zeus

    Timothy,

    When you say a blank refresh what do you mean the site loads as normal but the field is blank?

    Yes, like in the FAQ. The form and page reloads just fine, but the input box is blank and the info didn’t take.

    Let me know what happens with your host once they’ve done what they’re doing and if you still need help and for me to look at your install I can.

    We made IP change this morning. Waiting for it to propagate.

    Will report back.

    Thanks!

  • Temporal Sales
    • Site Builder, Child of Zeus

    Update:

    OK, we got the dedicated IP set up, fixed the DNS issues, and now I’m fairly confident the server is properly configured.

    I can reach each of my sub-blogs via its full pathname and my domain names resolve to the main blog with the sign-up message, which I understand indicates a properly functioning site, save for the mapping.

    However, even after re-installing the mapping plug-in, I can’t get it to accept the mapping inputs. I still get the “blank refresh” as described in the FAQ.

    Could we make arrangements for someone to take a look under the hood?

    Thanks

  • Temporal Sales
    • Site Builder, Child of Zeus

    Done.

    Thank you very much! Tried it myself and added the two other domains.

    For some reason you were missing a table for Domain mapping

    Could you provide some details of what was missing?

    It’s very concerning in that my new site only consisted of the lastest release of WP, the WPMUDev plug-in, and the WPMUDev mapping plug-in.

    Could a missing table suggest a bug in the software?

    Thanks again!

    Dan

  • Timothy
    • Chief Pigeon

    Hey again.

    It was the main table for storing the domains to be mapped. I added it with:

    CREATE TABLE IF NOT EXISTS 'wp_domain_mapping' (
    'id' bigint(20) NOT NULL auto_increment,
    'blog_id' bigint(20) NOT NULL,
    'domain' varchar(255) NOT NULL,
    'active' tinyint(4) default '1',
    PRIMARY KEY ('id'),
    KEY 'blog_id' ('blog_id','domain','active')
    ) ENGINE=MyISAM DEFAULT CHARSET=latin1 AUTO_INCREMENT=10 ;

    **If any ones uses this then you may need to change the wp_ to what ever prefix you use in the DB for WordPress””

    There could be a number of reasons for this and sure it could be a bug, I just wasn’t able to recreate the issue on my install which is why I’m not sure. It could have been some weird drop in connection whilst creating the DB or it could be something else altogether.

    I have of course passed this along to our developer who maintains this so he can review further.

    Take care.

  • Temporal Sales
    • Site Builder, Child of Zeus

    It was a frustrating two days trying to trouble shoot this, but it wasn’t unproductive as we did find and correct several errors in the domain structure and DNS.

    And of course, I made an erroneous assumption at the start that my VPS had an unique IP, which it didn’t.

    Again, many thanks for getting this fixed.

  • Josh
    • Flash Drive

    I posted in another Domain Mapping thread regarding the same problem. By performing the database fixes listed here and in the other thread, I was able to correct the problem (after several frustrating days).

    The database table “wp_domain_mapping” had been created as “wp_domain_map” and the row “map_ipaddress” did not exist at all.

    So, the combined database fixes did the trick. Not sure what’s triggering this anomaly with certain users, but I’d be happy to assist with debugging.

  • coburnenterprises
    • Site Builder, Child of Zeus

    Hi all, I couldn’t get the script to work for me above, but Tim had already fixed the missing row for me in the table called wp_domain_map that was created when we installed the plugin. So, I just copied wp_domain_map to create a new table called wp_domain_mapping and all works now. Looking forward to seeing this fixed – thanks to everyone for the input!

  • Timothy
    • Chief Pigeon

    Hey all.

    We now have an update available, please try that.

    Fixed IP

    ADDRESS NOT SET reporting bug

    Added extra checks in domain mapping options to check if dm table is created and

    if not attempt to recreate or display the required SQL if not possible.

    Updated check for DM_COMPATIBILITY to allow it to be set to No rather than need

    to be commented out.

    *Note* sunrise.php will need to be updated

    Thanks.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.