Crash site when activated Hummingbird.

Hummingbird constantly crashes the website once installed and activated. It seems to be the only plugin that causes a crash, I deactivated the rest of the WPMU plugins to test and it is the only one causing the problem.

  • Adam Czajczyk

    Hello Francis Bergeron,

    I hope you're well today!

    I checked your site, including replicating the issue with Hummingbird.

    The site fails due to reaching database connections limit. Hummingbird itself might use quite a lot of them, at least upon installation and initial setup (due to the nature of what it does) but there are also some other plugins that are "eating up" available connection limit.

    After removing Hummingbird again to get the site back online, I have checked current PHP settings directly on a server level (not via WordPress) and tested database usage via Query Monitor plugin.

    As for PHP. I know that you have been advised during the chat to increase WP memory limit and increase PHP max_execution_time. Unfortunately, as it turned out, those values weren't actually raised on your server. I have set WP Memory Limit back to 256M (as the current PHP memory_limit value is) which should be more than enough for your site and I have removed the line increasing max_execution_time as it didn't have any effect anyway (the limit was still at 30 seconds).

    However, the site seems to be slow even without Hummingibird. The Query Monitor still shows over 40 "slow queries" (most of them caused by WPML, Visual Composer and WooCommerce and their extensions) and the db connections limit is currently set to 100.

    That being said, I think it would be best to start with getting in touch with your host and asking them if they are able to raise those limits for you on their site:

    1. PHP "max_execution_time" - preferably to 300 seconds but anything over 150-160 should be fine as well

    2. mySQL "max_connections" - currently it's set to 100 which is fine for a simple site but here seems to be a "bottle neck". Default setting for mysql with Apache (and your site's running on LiteSpeed which is actually Apache fork - lighter and faster but still Apache core) webserver would be 151. So, while that doesn't seem like a big difference, it's definitely worth increasing. I would even go for as much as 256-300 if possible. That's something that can be changed on a server level, though.

    3. It would also be good to review LiteSpeed limits on connections; Due to the fact that site's a bit slow even despite sufficient memory limit and PHP 7.x (with only 20-something plugins active currently) suggests that there's some strict limit on those too, causing the webserver to "queue" connections, thus slowing everything down.

    That together should actually make the site perform better and most likely should also solve the Hummingbird issue. However, regardless of that, I'd also suggest running a full conflict test on site. That would mean disabling all the plugins (not only WPMU DEV ones), switching to Twenty Seventeen theme and then trying to install and enable Hummingibird to see if it breaks the site again. If it does, I'd say that would confirm the server-side issues. If it doesn't break, that would point to the conflict so the next step would be to:

    - switch to the current theme again and see if site breaks or not;
    - if it doesn't, enable plugins back one by one and see when it goes down and the last enabled plugin would be the most probable cause of the issue (either confirming conflict with the Hummingbird or causing too high resource usage on a server).

    Kind regards,
    Adam

  • kennibc

    I just posted about this as well. The most recent updates seems to have caused an issue on our servers with hummingbird. I got error messages in apache about blog cron and running hummingbird.

    Issues seem to stem from a file called hummingbird/core/class- logger.php line 150

    PHP Warning: fopen(wordpress/wp-content/wphb-logs//mcunis/-minify-debug.log

    Notice the "//" in the location. Might be a typo in the class-logger. I have a support ticket for this issue as well.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.