Create new layouts in builder

Dear WPMUDEV experts,
I was very excited about the upfront theme builder. I need to build a custom layout for the partners and team members in our sports club. Each Partner will get his page to present him- or herself. I created a costume theme but I am unable to create new layouts. I can only choose from a very limited list ("404 Page" "Maintenance Mode" "Home Page" Archive" Search"). I tried to rename the "Home Page" layout that is active when I start builder, but I could not find a way to do that. I also do not understand why the "Home Page" layout is the same thing as the default Post layout? I have made a little Video where I fight with builder and builder is winning! (I do document my fight in the video, so have fun watching)

https://vimeo.com/194198394/58a95b46d2

I hope you are having a great day!
kind regards
vassi

  • Nithin

    Hi Vassi,

    Hope you are doing good today.

    I created a costume theme but I am unable to create new layouts. I can only choose from a very limited list ("404 Page" "Maintenance Mode" "Home Page" Archive" Search".

    To create page layouts, you'll have to select Single Page layout. The list is not limited, you'll have to scroll, in order to see other layout formats.

    I tried to rename the "Home Page" layout that is active when I start builder, but I could not find a way to do that. I also do not understand why the "Home Page" layout is the same thing as the default Post layout?

    The post content what you see when you load builder is odd, it should show the Home page layout by default, ie the layout which you get when you edit the Home page by clicking the Edit Existing Layout. Could you please enable support access, so that we could give a closer look, and see how you have configured the layouts.

    It seems like you have somehow enabled the single posts to be shown in the frontend, rather than the homepage. Upfronts basic structure consist of the default Homepage, which acts like the frontpage. I'm afraid, there isn't any option to rename the default Homepage, you'll have to create a new layout using Single page layout, and once done, you can set that page as the frontend, under Settings > Reading > Front page displays

    You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please let us know once you enable access, so that we could have a better idea about this. Have a nice weekend.

    Kind Regards,
    Nithin

  • Nithin

    Hey Vassi,

    Hope you are doing good today.

    It seems like I'm getting an authentication message when trying to access your website. Could you please temporarily disable the authentication, so that we could check how Builder works on your system. It seems like the Single Generic page is being shown in the frontend when the Upfront Builder loads, instead of the Homepage layout, to be sure I would like to check your site.

    Please let us know once you made the changes, so that we could have a better idea about your system. Have a nice day.

    Kind Regards,
    Nithin

  • Nithin

    Hi Vassi,

    Hope you are doing good today.

    Unfortunately, I'm still getting the same authentication login box. If you are sure that this is not related to any of your plugins, this could be more related to your server. You'll have to get in touch with your host regarding this, in order to temporarily disable the authentication.

    To make it easier, you can send us your credentials along with the authentication login, so that I could check your website. You can send credentials by using our secure contact form: http://premium.wpmudev.org/contact/

    Select "I have a different question" for your topic.


    - To Mark to my attention, the subject line should contain only: ATTN: Nithin Ramdas
    -WordPress admin username
    -WordPress admin password
    -login url
    - Authentication username/password
    -link back to this thread for reference
    -any other relevant urls

    Have a nice day.

    Kind Regards,
    Nithin

  • Nithin

    Hi Vassi,

    Hope you are doing good today.

    Thank you for sending in the credentials, I checked your website, to see why Upfront Builder loads the sample post page, and the reason why that page gets loaded is because, you have configured to load a page as your frontpage, under Settings > Reading > A static Page

    When I disabled the frontpage, the builder will try to load it's homepage, since you haven't designed your homepage, it will presently appear as a blank page. If you are looking to load Start page as your frontpage, then all your Builder settings do look fine. Other than that, if you still have issue, please advise what I'm missing, so that we could help get this sorted. Have a nice day.

    Kind Regards,
    Nithin

  • Nithin

    Hi Vassi,

    Hope you are doing good today.

    Thank you for sending in the credentials, I checked your website, to see why Upfront Builder loads the sample post page, and the reason why that page gets loaded is because, you have configured to load a page as your frontpage, under Settings > Reading > A static Page

    When I disabled the frontpage, the builder will try to load it's homepage, since you haven't designed your homepage, it will presently appear as a blank page. If you are looking to load Start page as your frontpage, then all your Builder settings do look fine. Other than that, if you still have issue, please advise what I'm missing, so that we could help get this sorted. Have a nice day.

    Kind Regards,
    Nithin