Creating Categories Broken

In a new multisite installation I’m building, I’ve installed the new Directory Plugin. I went through Step 1 “Getting Started” – “First up, you need to configure your settings. This is where you can set the payment type, price and other settings.”

When I started on Step 2 – “Next, create new categories.” I got the following error:

“Invalid taxonomy”

That’s all the page says. The url for this error page is:

mydomain.com/wp-admin/edit-tags.php?taxonomy=listing_category&post_type=directory_listing

Thoughts?

  • Arnold
    • El Macho WP

    If you’re on Multisite go top Network admin and in CustomPress settings Make sure the persite checkbox is ticked.

    Then make sure directroy_listing post type is in CustomPress and listing_category and listing_tag are in Taxonomy. They should create themselves.

  • Troy
    • Site Builder, Child of Zeus

    In the CustomPress Settings, I’ve checked the “Enable sub-site content types” box and the “Keep the network-wide content types on sub-sites” radial button. I then saved the settings.

    I then went back to the Getting Started, Step 2 and it seems to be working!

    Nice work and thanks for all your work on this plugin. I know it’s challenging but a lot of us WPMU Dev Users seem to need this. Keep it up!

  • LubyG
    • Site Builder, Child of Zeus

    I have the same issue only do not see the verbiage you are referring to under CustomPress. Nothing says persite etc. See attached screen shot. Same thing, WordPress Network latest and same with the Directory Plugin.

  • Patricia BT
    • Connector

    @arnold, please tell me if “simple members” like me are allowed to answer, even if I might give wrong answers… ?

    @lubyg, this is the setting page in the (sub)site admin, you must check “Enable sub-site content types” in the network admin

    I myself have issues with directory, so I’m right now digging this forum :slight_smile:

  • LubyG
    • Site Builder, Child of Zeus

    Thanks Patricia, that was it. Yes, this system seems to hold promise. There are lots of great things that should be added. I suppose I should start adding questions and suggestions one at a time. For example, a way around the two year max on PayPal for those of us who have POS Virtual Terminal accounts with PayPal. Varied levels for listings by hierarchy per category and other tweaks.

    This plugin has come a long way since I first looked at it. Thanks!

  • novusweb
    • WPMU DEV Initiate

    I’ve just installed the new WPMU Dashboard. Very cool features. However, I don’t see the Custom Press settings in the Network Admin dashboard.

    I’ve install the latest Directory plug-in, but did not Network Activate it (I don’t need it on all sites). I do have the Dashboard plug-in network activated, of course.

    Attached is a screenshot of my Admin dashboard as I see it now.

  • LubyG
    • Site Builder, Child of Zeus

    Hi novusweb,

    Do Not Network Activate unless you want it to add directory pages to all your sub sites. I had to Network Activate it before I saw the Custom Press in my Network Admin.

    Then: Enable sub-site content types.

    When I went back to the main blog containing the directory I was able to add Categories. The problem is it added the pages for the directory to all my sub sites. Of course, that threw every sub site’s navigation into disarray. Luckily I run my own server and was able to restore a backup.

    Hopefully this can be fixed in a future release. For now there should be a H3 warning at the top that it is only compatible with Multi Site if you enable it across all sites.

  • Patricia BT
    • Connector

    on my side, I have multisite and buddypress, and Pro Site (the plugin from here)

    in my network dashboard, I have set directory to be available only to my main site (blog id 1), the one on which buddypress is also activated

    then on my site1 dashboard, I have activated under extension

    then the custom press and directory menu are there is the site1, and the network settings of custom press are also in the network dashboard (where I could check the above mentioned option)

    I believe this is the correct behaviour ?

    and @lubyg, if it may help you, for me it didn’t create the directory pages on all the other subsites. maybe you first activated from the network dashboard? or maybe for me it behaved correctly because Pro Sites helped restrict the use from other subsites?

    (I myself have other issues with directories, so don’t think I’m an expert :wink: just answering here in case my setup does help you)

    Cheers

  • LubyG
    • Site Builder, Child of Zeus

    Hi Patricia. It must have been due to Pro Sites. I’m trying to migrate our current website directory into a WordPress directory so it is mobile compliant automatically using the WP Touch Pro plugin. Looks like I’ll have to wait another year or so. I cannot afford to play around and not have it go right the first time. Too much time and money at stake. I’ll check this again in 6 months to see if there has been any progress. Thank you all for your efforts and time.

  • aecnu
    • WP Unicorn

    Greetings,

    It appears this particular topic is now resolved/closed, if you need any further assistance please let us know.

    If it wasn’t resolved, or you have any more questions related to this thread, please feel free to post them below including any new symptoms or errors and tick the ‘Mark as Not Resolved (re-open)’ box below the post area (or else we’ll miss it!)

    Thank you for being a WPMU Dev member!

    Cheers, Joe :slight_smile:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.