credit plans not being created

hi,
is the "MarketPress integration" add-on compatible with the new MarketPress 3 ?
reason i ask is because "credit plans" are not being created.
what is happening is every time i create a plan in "credit plans" and click save the screen just turns white.
no plans show up but they do show up in "products" (MarketPress) but without the pricing.
i tried adding in the price there (MarketPress) but they still do not show up in "credit plans".
i configured the rules as well as the pages in settings but basically no credit plans are showing both back end (credit plans) or front end (purchase credits).

support access granted if you wanna have a look and its a test/staging site so feel free to trouble shoot and make changes if need be.

your kind assistance and support in this would be greatly appreciated.
regards.

  • Vinod Dalvi
    • WP Unicorn

    Hi @amused,

    Sorry to hear of the problem you are having.

    I have tested it on my test site using latest versions of Jobs & Experts and MarketPress plugins and found it working fine as shown in the attached screenshots.

    I logged in to your site using support staff access and could confirm the issue that i am getting white screen when i try to create credit plan.

    Can you please try temporary enabling WP_DEBUG mode? To do this, just go to wp-config.php include this:

    define('WP_DEBUG',true);

    You might already have a line for WP_DEBUG, so just make sure it's set to true.

    For information on this, checkout this wpmu.org article.

    Let me know what errors if any you are getting when you face this issue.

    This can be due to plugin/theme conflict on your site.

    You can just try on your development site temporary using default WordPress theme like Twenty Fifteen and temporary deactivating all other plugins and activating them one by one as displayed in the following flowchart to know which theme/plugin is conflicting if any.

    https://premium.wpmudev.org/manuals/getting-support/

    Kind Regards,
    Vinod Dalvi

  • Vinod Dalvi
    • WP Unicorn

    Hi @amused,

    From your shared error log it seems the plugin buddy-bbpress-support-topic that you are using on your site is generating the error which may be causing this issue.

    To confirm it could you please try temporary deactivating this plugin and checking for plugin conflict as described in my previous reply?

    Regards,
    Vinod Dalvi

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.