Cross Browser Rendering Issue

The Pro Sites page renders differently in IE9 as compared to Chrome & Firefox.

The first image is Chrome - Firefox renders the same.

The second image is IE9 as it appears when the page very first loads. You'll notice that there is a section (top left) which shows up as being selected - but I didn't select it. The PayPal button also shifts right.

The third image is IE9, after selecting any other option besides the first one. Notice the odd color change that occurs?

There seems to be a browser issue happening so I thought you might want to look into it.

Thanks,

Corey


^^^ CHROME ^^^ (above) (Firefox renders the same)


^^^ IE9 at initial page load ^^^ (above)


^^^ IE9 with something other than the top left box selected ^^^ (above)

  • DavidM
    • DEV MAN’s Mascot

    Hi Corey,

    Not sure what's occurring there but I can't seem to replicate anything other than the squared bottom edges in IE9 (IE's tragic even with its latest version).

    Could you maybe try using Twenty Eleven theme for your main site to rule out any theme conflicts there?

    Thanks,
    David

  • NetPotion
    • The Incredible Code Injector

    Hi David

    I just tried the default theme and I'm getting the same thing.

    Oddly, it starts exhibiting the IE9 behavior in Chrome when I'm using the default template.

    Anyway, it's not the theme causing it.

    Internet Explorer is such a headache. Never fails.

    Thanks,

    Corey

  • DavidM
    • DEV MAN’s Mascot

    Hi Corey,

    Sorry, this one took a moment for me to see what was going on. That top-left box's color is different to reflect the Pro level of the current site you're setting that up for.

    It's the default plugin behavior. Not sure why it wouldn't display the same through the other browsers though. Assuming they were tested on a different site that wasn't a Pro site?

    -David

  • Philip John
    • DEV MAN’s Apprentice

    Hiya,

    As we haven't heard back from you we're going to assume the problem was sorted out and mark this thread as resolved.

    If it wasn't resolved, or you have any more questions related to this thread please feel free to post them below and tick the 'Mark as Not Resolved (re-open)' box below the post area (or else we'll miss it!)

    Otherwise, thanks for using the forums, and, as always, for being a member of WPMU DEV, it's a pleasure to help you out and we look forward to being of assistance in the future.

    Thanks!
    Phil

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.