Css problem after updating to 1.3

After i upgrade the plugin to 1.3 i see that the css breaks in my website.
Making little research i found that the default.css file is printed in Header.

How can i deregister this css from theme Functions.php file.
i would like to not load Plugin css at all. I am using my own css styles for this plugin that was implent in to the theme css and there is no reason as i can see to load it in the header if it is from optimization view or from logical view.

So, i would like to get some little help here with deregister the plugins css file from the header.

Thanks guys.

  • Timothy Bowers

    Hey there.

    From the admin area you can add your own CSS to take control:

    Admin --> Q&A --> Settings

    /wp-admin/edit.php?post_type=question&page=qa_settings

    I couldn't see default.css, maybe I missed it but could you provide the full path please.

    Or do you refer to the general.css? and custom.css?

    If so then:

    function removethatcss() {
    		wp_dequeue_style( 'qa-section' );
    		wp_dequeue_style( 'qa-section-custom' );
    	}
    
    	add_action( 'template_redirect', 'removethatcss', 11 );
  • Imedo

    Hey This one...
    http://www.****.com/wp-content/plugins/qa/default-templates/css/general.css

    And the code you provided helps !
    thank you.

    But i notice other problem now.
    When registered user post a question, the page goes back to this domain http://www.domain.com/questions/

    It shows blank page. And its only if the user post a question and redirecting to this page. The page as himself works great if you go to it directly but if user is redirected to it after posting the question it shows blank page.

    Any suggestions ?

  • Timothy Bowers

    Hey again.

    Glad the code worked.

    I was just testing your other issue there but I can't replicate that.

    This blank pack, is there nothing output there at all?

    Can you check your servers error_log?

    If you are unsure where that is then it might be best you check with your hosting provider they will know the setup best.

    Let me know what errors are being produced?

    Does this happen in the default Twenty Eleven theme?

    Does this happen with all other plugins turned off?

    If it then works you can activate each one, one at a time until the issue happens again. This will tell us where the conflict is if there is one.

    Let me know how you go.

    Take care.

  • Imedo

    Ok. I checked it and all i was need to do is to configure the thank you page in new Setting Page of this plugin.

    But i found some bug in this plug.

    If i choose to move the questions to pending automatically in setting page, the answers users publish goes pending too.

    There is no reason i can see why answers needs to go to pending mode :\.
    It applies to answers automatically and looks like a bug or something missed here.

  • Timothy Bowers

    If i choose to move the questions to pending automatically in setting page, the answers users publish goes pending too.

    There is no reason i can see why answers needs to go to pending mode :\.
    It applies to answers automatically and looks like a bug or something missed here.

    I think that might be intentional to help battle abusive comments going live straight away.

    Of course as this could be worded better to include Answers or as there could be a separate one for Answers I will ping our developer for clarification on this to be sure.

    Thanks.

  • Hakan

    Hi,

    If i choose to move the questions to pending automatically in setting page, the answers users publish goes pending too.

    As Timothy pointed out, that is intentionally programmed like that to remove all replies from a spammer who may have submitted hundreds of answers. You don't normally need to change a published question to pending. If you do so, it means there is a problem. I think that is a smart idea, and thanks to the original programmer (I am not the one who programmed that part).

    So that's not a bug, but intentionally done by design.

    Ok. I checked it and all i was need to do is to configure the thank you page in new Setting Page of this plugin.

    BTW, after the upgrade, plugin should have displayed a warning message to check all the settings and check for new ones. Even with nothing changed, only a single save of the setting page should have been enough to the new settings to be valid. So I didn't understand how you met something like this.

    Cheers,
    Hakan

  • Imedo

    @Hakan

    BTW, after the upgrade, plugin should have displayed a warning message to check all the settings and check for new ones. Even with nothing changed, only a single save of the setting page should have been enough to the new settings to be valid. So I didn't understand how you met something like this.

    Sorry but i didn't saw any warning massage in my wp.

    As Timothy pointed out, that is intentionally programmed like that to remove all replies from a spammer who may have submitted hundreds of answers. You don't normally need to change a published question to pending. If you do so, it means there is a problem. I think that is a smart idea, and thanks to the original programmer (I am not the one who programmed that part).

    So that's not a bug, but intentionally done by design.

    Not agree with you.

    Moving Questions to pending mode doesn't necessary means that there is Spam problem. It can be the administrant issue, that admin want to decide what question got there way to the public and wich of them not.

    Sorry but it doesn't make sense to me.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.