CSS question around clickable background logo

I run the site: http://www.xhotels.net

This is based on an affiliates program with hotelscombined.com. Once you select your destination and dates, you get redirected to:

http://hotels.xhotels.net/SearchResults.aspx?destination=city%3aParis&checkin=2012-12-26&checkout=2012-12-29&Adults=1&Rooms=1

As you will see, the landing pages looks very similar to the main wordpress site. However, I am stuck with the logo not being clickable. I am just starting to get my head around css, and although the logo has a "a href" tag, it can't be clicked. I would wan that logo in the top left to point to: http://www.xhotels.net Can I ask you for help with this one?

Thanks so much!

  • Paul Barthmaier

    Hi there and welcome to the WPMUdev Support Community!

    Cool idea! I hope it goes well for you. And I'm sure you'll find our plugins just the right thing for a venture like this, not to mention our Support! Ahhh, Support. Good folks and good looking, too!

    But back to your question! I'm not exactly sure what's going on with your child theme, but you might want to look at that. I have a screenshot of two things that will need attention. You'll notice that I have the logo there, but it's not yet functional and I don't think it can be on my side until you get the theming sorted.

    Cheers,
    Paul

  • Paul Barthmaier

    The first issue regarding being able to see the image has to do with the text-indent of the selector .logo-placement with a value of -9999px. This is a cute trick to that is done to get an item off the viewable screen. By unclicking that value, your image just popped back into position. Changing that value in your child theme to 0px will take care of that.

    But this other issue is about importing the CSS values from the parent theme. I'm surprised to see what's circled in red because that @import belongs in the child theme, but I don't think you should be able to see it in your source html. I think the issue may be that the URL wasn't properly declared, but I"m not sure. What you have is:

    @import url(http://www.xhotels.net/style.css);

    I think you should have quotation marks like:

    @import url("http://www.xhotels.net/style.css");

    I've also consulted with my colleague, @Patrick, our resident CSS wonk, who has an even better thought!

    Cheers,
    Paul

  • PC

    Hiya,

    Greetings and thanks for being a great community member.

    We haven't heard from you on this one for long and I am doing a regular followup to see if there is still something we can assist you on this thread.

    Just to manage the support issues more efficiently, I am marking this thread as resolved for now however this is not being done to avoid your questions in any ways.

    Please feel free to mark this is "Not resolved" in case you have further questions and we would be back on it.

    Thanks a lot for being with WPMU DEV.

    Cheers
    PC

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.