Cubepoint checkout problem

I've encountered some bizarre issues after I activated cubepoints to serve as the currency in my online store. Occasionally, once you add an item to the shopping cart (i.e. an item that "costs" 1000 points), the transaction cost resets to 1 point before the checkout takes place.

It doesn't seem to occur with every transaction, just intermittently (which is more troubling).

And I've checked, the transaction resetting to 1 point occurs even if the user has ample points available to make the transaction...

Any advice would be greatly appreciated!

  • thenutritionacademy
    • New Recruit

    Hey Phil,

    As you suggested, it isn't intermittent at all. After a bit more research, I think the problem might have to do with all the points values > 1000. Seems like the program is not reading further than the first digit. So 1,000 becomes 1... 1,250 becomes 1... 1,500 becomes 1... and so on.

    I tried to go back in and set the prices to 1000, 1250, etc (so no comma), but the program adds the comma after you save the entry... and idea how we can get this fixed?

  • thenutritionacademy
    • New Recruit

    HI Phil,

    Attached are the screen shots you requested.

    #1 - shot of edit product screen (where the comma is being added to price)
    #2 - how the 1000 point products looks in the store
    #3 - what happens after you add them to the cart
    #4 - what happens with a 500 point product added to cart as well (to show how it works fine on products with values < 1000 points)

    Hopefully you can help me get this working!

  • Philip John
    • DEV MAN’s Apprentice

    Okay, thanks.

    I definitely don't get that behaviour when I run any tests. Something, somehow, is adding that comma in when it shouldn't.

    Please disable all plugins other than MarketPress, revert to the default theme and try see if the comma is still being inserted.

    Also, can you tell me what version of WordPress and MarketPress you are using please?

  • thenutritionacademy
    • New Recruit

    Hi Phil,

    Current version:

    Wordpress: 3.3.1
    Marketpress: 2.4.2
    Cubepoints: 3.1

    Disabled every plugin (save marketpress and cubepoints), and reverted to a default theme... no change in in behaviour. Upon checkout, items worth 1000+ points get charged as 1 point.

    Even added a new product after all plugins were disabled to see if somehow it was a plugin that was messing with the product creation, but still no dice.

  • Timothy
    • Chief Pigeon

    Hey there! :slight_smile:

    Just checking in to see how things are going. :slight_smile:

    We haven't heard form you on this in a while (unless you have sorted this over email with one of our support gurus). So I'm going to presume your all fixed up now and don't need any further assistance.

    However if you have more questions or need some more help then please feel free to respond in this thread or create a new one and we will be more than happy to offer assistance. :slight_smile:

    Take care.

  • Timothy
    • Chief Pigeon

    Hey Kate.

    This is a rather older thread now and we have had many releases since it was started.

    Posting on the back of old threads could lead to your posts being missed so it is always best to create a new thread and link to one you believe relates. No worries, though just don't want to miss your posts :slight_smile:

    Which version of MarketPress are you currently using? Which version of WordPress are you using?

    Is the issue exactly identical to the one stated here?

    Thanks.

  • Kate McK
    • Flash Drive

    Hi Timothy,
    I actually bit the bullet and upgraded Wordpress (so I could the upgrade marketpress) and this has fixed the problem.

    Was just trying to avoid upgrading wordpress as it normally breaks other things (which it has, but hopefully they will be sorted soon).

    Thanks

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.