cURL 6: Couldn't resolve host 'audit.wpmudev.org'

A number of my websites that use the WP-Defender plugin have been giving a 504 Server error. I think I narrowed it down to WP-Defender throwing the error:

cURL 6: Couldn't resolve host 'audit.wpmudev.org'

Disabling the WP-Defender plugin seems to stop the constant 504 errors. I also can't update the WPMUDev dashboard, I tried on a few sites and it just doesn't update. On one site it put it in permanent Maintenance Mode (I deleted the .maintenance file to resolve that).

I asked my host, SiteGround, about this after doing a search for existing answers on wpmudev.org and here is what they said:

"Hello Joshua,

It seems the server it self can not resolve the doman audit.wpmudev.org as this is why the connection ends with such timeout. I tried to connect from few different shared and dedicated servers that we use however the connection was not possible.

I think there is a temporary issue with connection to the sub-domain that causes all those issues. Could you please contact the support team of wpmudev.org and ask them for more information about the issue.

Best Regards,

Simeon Boev
Senior Technical Support"

So, is there an issue with audit.wpmudev.org or other subdomains? Can ya help me out?

Thanks!

  • Kasia Swiderska
    • Support nomad

    Hello Smart Web Ninja,

    I have also hosting on SiteGround and I can't replicate both issues. I can update WPMU DEV Dashboard without problem and there is no 504 errors when using Defender and audit.
    It doesn't seem like this issue is on our side. I did research that and that error shows when there is problem on server side (like there is firewall).

    Are there any other errors in debug log regarding Defender? Would you mind allowing support access so we can have a closer look at this?
    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    kind regards,
    Kasia

  • Smart Web Ninja
    • Design Lord, Child of Thor

    I continue to experience this issue. It's only with the Defender plugin. As soon as I disable the Defender plugin, the rest of the WPMUDev plugins work fine and the website loads nice and fast and no longer gives the 504 error. I have resolved to no longer using WP Defender on any of my client websites.

    Thanks!

  • Nithin
    • Support Wizard

    Hi Smart Web Ninja,

    As soon as I disable the Defender plugin, the rest of the WPMUDev plugins work fine and the website loads nice and fast and no longer gives the 504 error. I have resolved to no longer using WP Defender on any of my client websites.

    If you meant this issue occurs only when you enable Defender, than that's an odd issue. Sorry to know that aren't gonna use WP Defender, the plugins helps in hardening your website, and with regular scans, and audit reports you will find it ease to keep you website secure.

    If you are still considering to troubleshoot this further, could you please enable support access with Defender installed in it, so that we could give a closer look. You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please let us know once you enable access, so that we could get this sorted. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.