Custom admin bar do not currently have privileges on this site

Hi, I've read some help posting about my issue but not sure if they are what I need.

I've added links to the ultimate branding >Custom Admin Bar.

Examples:
edit.php?post_type=product&page=marketpress

options-media.php

index.php?page=msreader.php

options-general.php?page=blog-avatar

admin.php?page=add-new-ticket

All these give the user error message

"You attempted to access the "3D Artist Network" dashboard, but you do not currently have privileges on this site. If you believe you should be able to access the "3D Artist Network" dashboard, please contact your network administrator.
If you reached this screen by accident and meant to visit one of your own sites, here are some shortcuts to help you find your way.
Your Sites
Virtual Fashion Visit Dashboard | View Site"

Then they have to click their dashboard link to get in the area.

How can I fix this so they go directly to the spot they need to be in?

Thanks
Kimberly

  • Tyler Postle

    Hey again Kimberly,

    Are the users able to visit these pages from the admin area without any issues? It's just those specific links that stop them?

    It sounds like a user role capability issue, you will want to make sure they have the correct capabilities to access those pages.

    If they do and it's still happening, do you mind granting support access so we can take a closer look?

    Look forward to your reply!

    Cheers,
    Tyler

  • Kimberly

    Hi, I'm having all kind of issue.

    1) First this is subdirector folds and not subdomain. I could never get subdomain to work and assume it too late to change to subdomains.

    2) When I signed up for a separate test account and click the Activate account link on the email I get then after a long wait, it activates the account.
    Warning: Missing argument 1 for wpseo_activate(), called in /home/vintag80/public_html/3DArtistNetwork.com/wp-content/plugins/wordpress-seo/wp-seo-main.php on line 224 and defined in /home/vintag80/public_html/3DArtistNetwork.com/wp-content/plugins/wordpress-seo/wp-seo-main.php on line 110

    3) When I click log in "Your account is now activated. View your site or Log in" It takes me to visit a my site and not log in.

    After I go to the homepage and log in. I use the admin dashboard and on any link get

    4) You attempted to access the "3D Artist Network" dashboard, but you do not currently have privileges on this site. If you believe you should be able to access the "3D Artist Network" dashboard, please contact your network administrator.

    If you reached this screen by accident and meant to visit one of your own sites, here are some shortcuts to help you find your way.

    Your Sites

    myaccount Visit Dashboard | View Site
    -----------------------

    For me at least, once I click Visit Dashboard I'm ok for this visit but each time I log back in, I have to click the visit dashboard again.

    I've heard from a couple of users then must click the visit dashboard every time they use the admin bar. Not just clicking it one.

    ----------------------------

    If it going to be a huge issue then I live without the branding plugin or admin bar.

    Thoughts?
    Thanks
    Kimberly

    • Tyler Postle

      Hey Kimberly,

      Thanks for all the information here, it definitely helps with finding a solution!

      With the information you've given, I'm thinking this is a plugin conflict. The URL you have should work, especially if you haven't done anything with the user roles.

      Can you deactivate Wordfence, WordPress SEO, and Super Cache then check again to see if the links are working correctly for your users? Caching can sometimes cause the permission error on the backend. Make sure you clear your browser cache and everything before testing it.

      If that doesn't do it then can you send me your FTP and WP login via our private contact form? Then I can take a closer look and do some further testing if that's okay :slight_smile:

      Send in(if needed):

      Subject: "Attn: Tyler Postle"
      -WordPress admin username
      -WordPress admin password
      -login url
      -FTP credentials (host/username/password)
      -link back to this thread for reference
      -any other relevant urls

      Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me :slight_smile:

      https://premium.wpmudev.org/contact/

      It sounds like a user role capability issue, you will want to make sure they have the correct capabilities to access those pages.

      Just to address your question about this line. Since you don't have a user role editor plugin, then you don't need to worry about this. Your roles aren't likely changed :slight_smile:

      Look forward to hearing from you Kimberly!

      Cheers,
      Tyler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.