custom fields data is not displayed in the site

I installed CustomPress in fresh install of WP 3.0.4.
I did the tutorial of Books database.
I am able to enter the custom fields data (Year and Book Rating) when adding a New Book.
Everything works fine, except that there is no way to add/assign Genre and/or Author. This is the message displayed under Genre and Author:
"You cannot modify this taxonomy."

The other issue is that taxonomies and custom posts data are not displayed in the live site, even though the file single-books.php was succesfully created by the plugin and modified as instructed in the tutorial.

Our test site is

Thanks for your help.

  • cbriere

    This is the code added to the single-books.php file:

    <div class="entry-meta">
    <?php twentyten_posted_on(); ?>
    <?php echo get_the_term_list( $post->ID, 'Genre', 'Genre: ', ', ', '' ); ?>
    <?php echo get_the_term_list( $post->ID, 'Author', 'Author: ', ', ', '' ); ?></p>
    <p> </div><!-- .entry-meta --></p>
    <p> <div class="entry-content">
    <?php the_content(); ?>
    Year Book Written: <?php echo get_post_meta( $post->ID, '_ct_text_4d1dd9e84fcb2', true ); ?>
    Book Rating: <?php echo get_post_meta( $post->ID, '_ct_text_4d1dda09d2853', true ); ?></p>
    <p> <?php wp_link_pages( array( 'before' => '<div class="page-link">' . __( 'Pages:', 'twentyten' ), 'after' => '</div>' ) ); ?></p>
    <p> </div><!-- .entry-content -->

  • Mason

    Hiya cbriere,

    The "You cannot modify this taxonomy." message pops up if you're using a user role less than Super Admin. This will be changed in the next update of the plugin.

    Can you do a test post on the install? I took a look and didn't see one. What I'm looking for is to see if the words "Year Book Written:" and "Book Rating" show up on the post. If they do, then there's something wrong with the php embed code. If those words also don't show up then the code has been placed in the wrong spot or the file isn't being used properly.

    Let us know when you have a test post that should use the custom file and we'll take a look.

  • cbriere

    Hi masonjames,

    Regarding the Super Admin comment, I am not using WPMS in this install. Just WP.
    However, posts were done by system admin, me.
    Do CustomPress works only with WPMS?

    Second, the site now have 2 test posts.

    Finally, the words "Year Book Written:" and "Book Rating" dont show up on the posts. So please, state where Exactly I have to insert the codes. I inserted them in the same spots shown in the tutorial image. Maybe some instruction on where to insert it will solve the issue.


  • wlpdrpat

    Hey cbriere,

    Changing a WP install to a WPMS install takes about 2 minutes. It actually took me longer to read this article than it took to make the necessary changes: Create A Network

    However, I don't know if you need a MS install for the plugin or not but for the sake of a couple minutes it would be worth changing your site to MS anyway.

    Regarding the display issue with CustomPress - it would appear on your site that your homepage and single page are still using the default display instead of the custom one created by the plugin.

    Check the CustomPress settings page and ensure that "Default" is not checked.

    The plugin is supposed to create the custom display files for you if your permissions are set properly on your server. If it can't create the files then I would suggest changing the permissions on your custom theme folder to 777 and allow the plugin to create the required files - then for security you can change the permissions back to 755 if you prefer.

    The embed codes created by the plugin are designed to be placed into your theme in the defaults if you are going to use them by default (or at least that is my understanding). The custom display files that are created allow you to use both the custom display and the default but you need to select them as the display for the appropriate posts.


  • cbriere

    Hey wlpdrpat,

    Thanks for the reply.
    For the moment, I will have to keep it non-Multisite.

    I just noticed from WPMUDEV plugins website that CustomPress is compatible with WordPress 3.0.1 and WordPress Multisite 3.0.1. I am using WP 3.0.4. Maybe that could be the issue.

    As per your suggestion, I checked the CustomPress settings page and ensured that "Default" is not checked. Finally, the plugin also successfully created the custom display file for me (single-books.php).


  • Mason

    Hiya cbriere,

    This plugin is designed to work in a single-site scenario so you shouldn't need to activate multi-site. It also should be just fine with 3.0.4 but compatibility information wasn't updated with the latest releases of WordPress. I'll get that changed.

    Assuming the plugin is setup correctly, it appears that WordPress is not using the single-books.php file for your custom post types.

    Some servers are very particular about their rules on capitalization. Can you make sure that the custom post type is 'books' and not 'Books' The labels can be capitalized or not, but make sure the actual post type and the file (single-books.php) match up.

  • Mason

    Hiya cbriere,

    Sorry for the delayed response. This one appears to have fallen through the cracks.

    However, taxonomies we added while creating the post are not displayed.

    You'll have to make sure the taxonomies are attached to the new post type you created (with the lowercase name).

    Also, when I edit the post it still have the message "You cannot modify this taxonomy." and I am unable to tick/untick the taxonomy/categories Genre and Author. How do I correct that issue?

    Read my response above:

    Are you using the latest version? There is now an option where you can make these taxonomies editable by users with lower than Super Admin privileges:

    Hope this helps! Let us know!