Custom Google Search is throwing an error and not showing search results

Custom Google search is not working. It is throwing an error: “Unauthorized access to internal API. Please refer to

I’ve tried deactivating the plugin and reactivating, no success.


I found this on posted 6 days ago:

In addition, Custom Google Search Help says this:!topic/customsearch/4J_hDR7pIf8

“The Custom Search Element API 1.0, which was deprecated in 2012 in favor of API 2.0, is now no longer maintained. API 1.0 will stop working on December 4, 2017.

You can check if you’re using the 1.0 version by looking at the code on your search page for a call to If you are, read on:”

I checked the code and ours does say:

It also doesn’t work on Energy Institute. I was looking for other sites that use this plugin.

  • Farhad Fatahalian
    • WPMU DEV Initiate

    Hi – Yes, the update fixed the search results issue. However, I am not able to have the search results show up on a search results page as before. The widget itself used to have a dropdown where you could select to have the results on the same page. But, that option is no longer in the widget.

    I’ve selected: “Open clicked search result in same window” in the Custom Google Search Settings, but it still displays the results in a popup window.

    I’ve also tried using a custom page setting, but in every instance, the results are displayed in a popup window.

    Thanks for any help.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.