Custom Google Search plugin using deprecated api

I’m seeing this warning and I’m relying on this plugin. Is there going to be an update that moves to the latest version of the Custom Search API?

this is what it says in javascript errors/warnings.

This page is calling an old version of the Custom Search API, which is deprecated and will stop working soon. In order to avoid an outage for the search results, the call for search results must be updated to the current version of the Custom Search API https://developers.google.com/custom-search/docs/element.