Custom Google Search Widget No Longer Working In UberMenu

We have a Custom Google Search widget in an UberMenu menu item that is no longer working. Here's a screenshot of what it says now: http://smb-infogroup-dpr.d.pr/1bG5X/3S27YypC

I don't know how the widget got removed from the UberMenu item, but when I add it back in there the page goes 502. I'm not sure if this is a support request for WPMU for the Custom Google Search plugin or UberMenu, so I'm opening a support request with both.

Thanks.

  • Adam Czajczyk

    Hello Infogroup,

    I hope you're well today and thank you for your question!

    I suppose that the Custom Google Search widget is currently added to the UberMenu as the site is not loading, returning 502 error instead.

    Are you able to access site's dashboard or does this take down entire site?

    If you're not able to access admin dashboard, please access the site via FTP and then go to "/wp-content/plugins/" folder and change the name of the "custom-google-search" folder to e.g "custom-google-search-OFF'. This should disable the plugin and let you access dashboard.

    Then please remove the widget from Uber Menu and try putting it to any other "regular" sidebar on your site just to see whether it's causing the same error or not.

    I'd also suggest performing a full theme/plugin conflict test in order test as described on a flowchart in this article:

    https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Let me know about the result, please!

    Best regards,
    Adam

  • Dimitris

    Hello Infogroup,

    I hope that you're doing really good today and don't mind skipping in! :slight_smile:

    I'm glad that you narrowed that down to these two plugins. So, I just want to see if there are any other errors generated whenever you hit that 502 error page. Please go ahead and edit wp-config.php file (you should be able to reach this through FTP) and replace
    define('WP_DEBUG', false);
    with

    // Turn debugging on
    define('WP_DEBUG', true);
    // Tell WordPress to log everything to /wp-content/debug.log
    define('WP_DEBUG_LOG', true);
    // Turn off the display of error messages on your site
    define('WP_DEBUG_DISPLAY', false);
    // For good measure, you can also add the follow code, which will hide errors from being displayed on-screen
    @ini_set('display_errors', 0);

    Then go ahead and replicate this 502 error while keeping all other plugins deactivated.
    After doing so, an error log file should be created in /wp-content/debug.log.
    Download and rename this file to debug.txt and attach it here (you must rename it in order to be able to attach it).

    Looking forward for your results!

    Warm regards,
    Dimitris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.